Author Topic: XML data not updating  (Read 14780 times)

lukem

  • Guest
Re: XML data not updating
« Reply #15 on: April 17, 2013, 08:11:36 PM »
If you paste http://iceguide.icetv.com.au/cgi-bin/epg/iceguide.cgi?op=xmlguide&desc_length=1500 into your browser, and enter your username and password when prompted, do you receive the guide?

The above URL works for me.

Offline Starionx

  • Junior Member
  • **
  • Posts: 16
    • View Profile
Re: XML data not updating
« Reply #16 on: April 17, 2013, 08:25:31 PM »
CRAP!
Yes, it works. Well I'm running out of ideas.  :(

lukem

  • Guest
Re: XML data not updating
« Reply #17 on: April 17, 2013, 08:28:30 PM »
Is your DNS returning the correct IP address for iceguide.icetv.com.au?

You could also try replace iceguide with www and see if you get the same result.

Are you using a proxy? Does your ISP use a proxy?

Offline dfindlay

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: XML data not updating
« Reply #18 on: April 17, 2013, 10:45:01 PM »
I would just like to advise that I have the exact same issue.  My region in Melbourne.  ISP is Internode.  There is no proxy either locally or at my ISP.  The XML connection via JustEPG has worked perfectly for years and just stopped working 11 April.  No changes to JuspEPG at my end, so it would seem that something has changed at the IceTV end.

If I manually go to the XML URL in a web browser, it asks for username and password and when I enter them it returns a bunch of data.  But I never tried this prior to 11 April so I am not sure if the behaviour is any different.  Since someone mentioned that the error suggests something about an authorisation issue, my next question to IceTV support guys would be did anything change with your web server authentication protocol??

   Dave

Offline Paul55

  • Guru
  • *****
  • Posts: 397
    • View Profile
Re: XML data not updating
« Reply #19 on: April 17, 2013, 10:46:32 PM »
Don't know if you still need this;

10 April, 2013 at 10:55pm with XML
17 April, 2013 at 10:26pm with Topfield TRF-2400

Brisbane
bigpond
adsl

I have made no changes to JustEPG for months and my Toppy is accessing the internet normally - including IceTV for 'normal' EPG data.

Daylight saving is not an issue because I live in QLD.
« Last Edit: April 17, 2013, 10:51:32 PM by Paul55 »

Offline Paul55

  • Guru
  • *****
  • Posts: 397
    • View Profile
Re: XML data not updating
« Reply #20 on: April 17, 2013, 10:50:31 PM »
Accessed the XML data via the link posted by Luke.
IceTV - My Account, shows it as a fetch.

Offline Dave at IceTV

  • Guru
  • *****
  • Posts: 1258
    • View Profile
    • IceTV Knowledgebase Articles
Re: XML data not updating
« Reply #21 on: April 18, 2013, 07:55:51 PM »
Hi guys,

What's happening is the request for the xml file is arriving from JustEPG without any IceTV login details. Our recent server move seems to have highlighted a bug in JustEPG. We (you) need the current JustEPG author to have a look at how it requests the file download.
cheers

Dave
Customer Service

lukem

  • Guest
Re: XML data not updating
« Reply #22 on: April 18, 2013, 08:06:25 PM »
I'm thinking out loud here, but I wonder if the bug in JustEPG is related to same bug in the Topfield as to how it handles HTTP headers. HTTP headers can sometimes contain more information when traffic is passed through smart load-balancers. The Topfield does not like this (even though the headers conform to the standard) so we work around the Topfield bug by routing Topfield traffic (which hits remote-topfield.icetv.com.au) through an IP-only load-balancer.

To test this theory, could you please replace iceguide.icetv.com.au in the JustEPG INI file with remote-topfield.icetv.com.au?

Cheers,
Luke

Offline Starionx

  • Junior Member
  • **
  • Posts: 16
    • View Profile
Re: XML data not updating
« Reply #23 on: April 18, 2013, 09:03:13 PM »
I'm thinking out loud here, but I wonder if the bug in JustEPG is related to same bug in the Topfield as to how it handles HTTP headers. HTTP headers can sometimes contain more information when traffic is passed through smart load-balancers. The Topfield does not like this (even though the headers conform to the standard) so we work around the Topfield bug by routing Topfield traffic (which hits remote-topfield.icetv.com.au) through an IP-only load-balancer.

To test this theory, could you please replace iceguide.icetv.com.au in the JustEPG INI file with remote-topfield.icetv.com.au?

Cheers,
Luke

WooHoo. Works like a charm.
 :) :) :) :)

Offline Starionx

  • Junior Member
  • **
  • Posts: 16
    • View Profile
Re: XML data not updating
« Reply #24 on: April 18, 2013, 09:18:37 PM »
For those who don't know where to make the change, use the following steps.

You will need to access a file called xmltv.ini. This will be in 'ProgramFiles/Settings/EPG' in the Toppy directory. You will need to access this from an FTP client e.g. Filezilla. The file will have the following data -

[Fetch]
Host=iceguide.icetv.com.au
Path=/cgi-bin/epg/iceguide.cgi?op=xmlguide&desc_length=1500
Username=xxxxxx
Password=xxxxxx

(the username and password will actually have your username and password)


You need to change the 'Host=' line to read -

Host=remote-topfield.icetv.com.au

Save this file. Go into Justepg and change the EPG Data Source back to XMLTV WEB (if you changed this while we had the problem).
If you also disabled the Toppy settings for Icetv, then you will need re-enable it.
Go back to Justepg and reload the EPG.

Sadly, I have to go to work now, so if anyone still has problems, maybe someone else could give them a hand.  :)

Thanks Luke for 'thinking out loud'.  ;D

Offline dfindlay

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: XML data not updating
« Reply #25 on: April 18, 2013, 11:18:34 PM »
That's fantastic.  Works a charm for me too.   ;D

Thanks a heap to Dave and Luke at IceTV for their attention to this and for everyone working together to find a solution.

Cheers,
   Dave

Offline Paul55

  • Guru
  • *****
  • Posts: 397
    • View Profile
Re: XML data not updating
« Reply #26 on: April 19, 2013, 06:24:55 PM »
Another confirmed fix here. Took me two goes because I left the .iceguide. in the line. DOH!

Offline ggm@pobox.com

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: XML data not updating
« Reply #27 on: April 20, 2013, 12:51:21 PM »
instant fix. many thanks.

An Error Has Occurred!

Call to undefined function seo_social_bookmarks()