7500T crashing like crazy

Started by 359, June 23, 2014, 07:47:51 AM

Previous topic - Next topic


Hi all.  I am having major issues with my 7500T, lock ups and reboots.  Unable to use really.  Just before buying something new, I'd like to reload the firmware but I cant get onto humax support to get a fresh firmware download, some weird 'no db' error on their site?

Can anyone send or link to firmware 1.08.09 please?  This has been mentioned around these parts as a safe option.

Currently it is on 1.08.22 and a7.54

Thanks for any help :)


Well, tried a copy of 1.08.09, didn't help after all.  Guess it will be a call to humax hq tomorrow for repair.

Wonder if it will be worth to fix.. cheers


Factory reset it yet? Also if using wifi pull out the dongle and see if it settles. Ah one more thing.  How many tracks/files on the hdd? Too many files will make it reset all the time.  Eg i put  2000 music tracks on and had the same issue.
I'd be formatting the disk too if none of these work before sending it back


Thanks, tried these suggestions, also tried on component outputs and another tv with another hdmi lead.  No go.  After 5 mins, it locks up, no response to remote.  Checked fan is clear, no dust so hope no overheating. 

Before I do anything else, will call Humax.  The unit is 2 years and 29 days since purchase so question is, will they be heroes and honour the 2 year cover or play hard ball and charge?!  Fingers crossed!


That is bad luck.  I'd be surprised if they did not come to the party as consumer laws enforce a reasonable expectation of lifetime.
That been said it made me think what I'd do if my unit which is a similar age died. The Humax has failed in so many areas for me that I hate to say it but I'd probably go the fetch deal with Optus. The only reason I keep the Humax is the pause live TV the guide and recording live TV.  And there's not much to record anymore. 


Well, Humax offered to replace hdd for cost. That was still $170 so said no and thanks. So took apart now warranty is no good. While poking about, got huge shock from a component, see attached. Not sure, might replace it if able to source


That looks like an amplifier and unlikely the issue.  I'd be checking the fans in the unit.  If they are OK I would suspect the cpu is cooked or the hard drive.


Spontaneous rebooting could be caused by a PC running PowerDVD which can cause some DLNA devices to go into a rebooting loop. It does this the Topfield TRF-2400/2460 but not, as far as I can work out, the TF-T6000. All you need to do is disable any PowerDVD related services.

IceTV: 2xTRF-2400 + 2xTF7100HDPVRtPlus + SKIPPA [RIP] + T2 + U4 + V2
No IceTV: a few Toppys
Synology NAS
Check out the oztoppy wiki and oztoppy Forum for Toppy help