My HDR-7500T/1TB is miss behaving badly

Started by dpark, April 28, 2014, 03:32:55 PM

Previous topic - Next topic


My HDR-7500T/1TB is miss behaving badly.

Its on software 1.08.21 with loader a7.54

On the weekend it was not recording the sound of a program I started to watch part way thru. I stopped the recording and tried to turn the machine on and off to get the sound back. This didn't work and that particular channel (Ch73) remained with no sound. I tried to watch another program recorded several days earlier and everything froze. The remote would not get it off trying to open the media menu. In the end I turned on and off at the main switch on the back. After that the next hour involved lots of on/off trying to get it to start and hold a program. It sometimes showed a channel then other times said ' no programs currently being broadcast on this channel' then sometimes just locked up. A few more restarts then I gave up for a few hours. I tried again but no luck so I did a reset to factory defaults and then set everything up from scratch. If anything its worse. No recordings will now play or will it stay on the channels for very long. And it cannot record anything. It just seems to be sort of stuck freezing constantly.

Any tips on what to try next?



So it has been working fine? It sounds like the tuners have a hardware fault. Its a two year warranty and I'd be sending it back

BTW was it in a well ventilated position? They do get quite warm in operation


Yes up till sat everything had been working fine. Its is quite well ventilated but just in case I have removed it completely so its on its own now.

Tried again last night. Still no joy. There seems to a massive (as in minutes) lag with every command you send thru on the remote. I did several power off restarts.  I tried swapping the internet connection from LAN to the wifi to try and trigger a change but nothing. All channels work (but with a minute or 2 lag when chosen) and you can program it to record but you cannot play back any media, it just locks up. Even heading into the settings menu everything is very laggy and things don't seem to want to work. Nothing programmed via the web or the app work. I even tried the Humax Remote App, which did work but was just as laggy, and it couldn't play any pre-recorded shows.


Darren Park


yep call Humax and send it back. sounds like hardware failing


Hi, did you ever reach what was wrong? Similar issues for my hummy. Cheers