Author Topic: Timer status not updating  (Read 2201 times)

Offline DeltaMikeCharlie

  • Full Member
  • ***
  • Posts: 57
    • View Profile
Timer status not updating
« on: June 16, 2018, 10:47:30 AM »
I'm not sure if I am doing something wrong, or if there is a bug in the API.

When I receive a new timer from ICE with a "waiting" status, I create the timer on the PVR and then send back a status update to "pending".  However, this status is not always reflected on the ICE portal.  Normally, the timer icon on the portal will change from "Queued Single Recording" to "Single Recording" when the "pending" status is returned.

It seemed to happen more prominently for the last timer in a group of timers.  However, I just did a quick test as I was preparing for this post and I found that it seems to always be the last timer that is not correctly updated, regardless of how many were processed.

As a test:  I started with 2 groups of 3 timers.  In the first group, all 3 timers showed as "Single Recording", however, in the second group, only the first 2 showed as "Single Recording" and the third showed as "Queued Single Recording".  The timers were in this state for several polling cycles and in my log file I could see ICE continuously sending "waiting" messages for the "Queued Single Recording" timer, even though I was continuously sending "pending" responses.

I then created another single timer and then the last timer of the second group suddenly became a "Single Recording" and now the new single timer appears to be stuck on "Queued Single Recording".

Has any one else encountered this issue?

Also, this only seems to happen with timers sent from ICE.  If I create a timer on the PVR and then send it to ICE, the ICE portal immediately shows the timer as "Single Recording" but leaves the previous "Queued Single Recording" still in its "waiting" state.

Perhaps a workaround would be to never accept an ICE timer.  Always send a deletion request back to ICE for timers created by the portal, but then create a manual timer on the PVR for the same event and post that manual timer to ICE as a new timer.

Offline Daniel Hall at IceTV

  • Administrator
  • Guru
  • *****
  • Posts: 1278
    • View Profile
    • IceTV
Re: Timer status not updating
« Reply #1 on: June 16, 2018, 12:00:19 PM »
Hi DeltaMikeCharlie,

Can you send any more details including the accounts being used (and any id's that you have) to developer@icetv.com.au so we can check it out.
Regards,

Daniel.
CTO.

Offline DeltaMikeCharlie

  • Full Member
  • ***
  • Posts: 57
    • View Profile
Re: Timer status not updating
« Reply #2 on: July 26, 2018, 11:53:54 AM »
Hi Daniel,

Did you receive the email that I sent on 17-June?

Has there been any progress on this issue?

Offline Daniel Hall at IceTV

  • Administrator
  • Guru
  • *****
  • Posts: 1278
    • View Profile
    • IceTV
Re: Timer status not updating
« Reply #3 on: July 26, 2018, 05:03:13 PM »
Hi DeltaMikeCharlie,

Yes, I have the email but unfortunately have not been able to dig through the issue as yet.

Will hopefully have something back to you in the first half of next week with some other observations on the interaction of the TAP as well.


Share via facebook Share via twitter

clip
Duplicate Timers, Duplicate EPG ...

Started by BazzaG on IceTV EPG Content

0 Replies
143 Views
Last post July 13, 2020, 09:01:06 PM
by BazzaG
xx
Timer with different symbol - Android vs Web

Started by vader1111 on General Discussions

4 Replies
185 Views
Last post June 19, 2020, 10:10:46 PM
by vader1111
xx
Timer conflicts

Started by Nistrod on Beyonwiz

17 Replies
494 Views
Last post June 10, 2020, 02:38:42 PM
by prl
question
Catalyst ... online indicates it's set for recording but NO timer on my U4

Started by BazzaG on Beyonwiz

14 Replies
585 Views
Last post June 21, 2020, 07:16:35 PM
by BazzaG