Author Topic: what weve been waiting for  (Read 8193 times)

Offline lcrowhurst

  • Newbie
  • *
  • Posts: 2
    • View Profile
what weve been waiting for
« on: January 31, 2005, 07:57:53 PM »
this is what weve been waiting for, legal program guide, bring it on !! :D

Offline wayfarer

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: what weve been waiting for
« Reply #1 on: January 31, 2005, 09:44:58 PM »
Can anyone tell me when we will be able to trial an ICE EPG service for MCE?  


Offline lcrowhurst

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: what weve been waiting for
« Reply #2 on: January 31, 2005, 10:13:40 PM »
contact peter at

peter.vogel@icetv.info

he is running a beta program

Offline Shane

  • Senior Member
  • ****
  • Posts: 181
  • Vista Premium & Elgato EyeTV User
    • View Profile
    • shasam.net
Re: what weve been waiting for
« Reply #3 on: February 01, 2005, 08:32:58 PM »
Found this tool which may do what we want with this data without having to install webguide/smartguide.

The postings start here:
http://www.thegreenbutton.com/community/shwmessage.aspx?ForumID=27&MessageID=89419&TopicPage=1

The latest version I have found so far (QuickGuide2005Beta1WithSource20050131.zip) is here:
http://www.thegreenbutton.com/community/shwmessage.aspx?ForumID=27&MessageID=89419&TopicPage=4

I'm going to give it a go tonight.

Regards,
Shane.
Shuttle SB83G5M (P4 630 nVidia 6600) running Vista Premium with:
Hauppauge Nova-T 500 MCE Tuner|Ice TV Guide|PIMP|Buffalo LinkStation HD-H160LAN & HD-HG300LAN|Xbox 360 MCE

Offline BJReplay

  • Full Member
  • ***
  • Posts: 57
    • View Profile
Re: what weve been waiting for
« Reply #4 on: February 01, 2005, 08:49:11 PM »
Quote
Found this tool which may do what we want with this data without having to install webguide/smartguide.

The postings start here:
http://www.thegreenbutton.com/community/shwmessage.aspx?ForumID=27&MessageID=89419&TopicPage=1

The latest version I have found so far (QuickGuide2005Beta1WithSource20050131.zip) is here:
http://www.thegreenbutton.com/community/shwmessage.aspx?ForumID=27&MessageID=89419&TopicPage=4

I'm going to give it a go tonight.

Regards,
Shane.
Shane, QuickGuide will work with the iceTV data, but doesn't map all the categories.  It will probably be a couple of days until I come up with a really robust solution to this, but in the meantime, you can always edit up your own categories.txt so that they all appear in MCE.

BJ

Offline Shane

  • Senior Member
  • ****
  • Posts: 181
  • Vista Premium & Elgato EyeTV User
    • View Profile
    • shasam.net
Re: what weve been waiting for
« Reply #5 on: February 01, 2005, 08:52:28 PM »
Thanks! I'm pretty damn excited about getting this going... have already altered the categories file a bit to match some of the main categories my wife and I watch... shall see how it goes!

Thanks for the good work!

Regards,
Shane.

Offline Shane

  • Senior Member
  • ****
  • Posts: 181
  • Vista Premium & Elgato EyeTV User
    • View Profile
    • shasam.net
Re: what weve been waiting for
« Reply #6 on: February 01, 2005, 09:55:20 PM »
Quote
Shane, QuickGuide will work with the iceTV data, but doesn't map all the categories.  It will probably be a couple of days until I come up with a really robust solution to this, but in the meantime, you can always edit up your own categories.txt so that they all appear in MCE.

BJ

I've just installed the latest version, and I get no errors at all and the excrypted XML is created, but MCE is not seeing it - I get "No Data Available" coming up next to all of my channels. If I go in to assign guide data to channels, the only option I get is to not display guide data for this channel.

Any ideas?

Regards,
Shane.

Offline BJReplay

  • Full Member
  • ***
  • Posts: 57
    • View Profile
Re: what weve been waiting for
« Reply #7 on: February 01, 2005, 09:59:51 PM »
Quote

I've just installed the latest version, and I get no errors at all and the excrypted XML is created, but MCE is not seeing it - I get "No Data Available" coming up next to all of my channels. If I go in to assign guide data to channels, the only option I get is to not display guide data for this channel.

Any ideas?

Regards,
Shane.
Three thoughts - Firstly, did you run the Enable .reg file to enable the Guide in MCE (it sounds like you have, from what you say, but worth asking anyway).

Secondly, have you customised the ChannelInfo.XML file - I've attached mine (customised for Melbourne channels).  If you haven't you've probably ended up with a tiny output file - because QuickGuide skips data in the XMLTV file if there isn't an entry in ChannelInfo (because it doesn't know how to map the data in XMLTV to the internal IDs MCE is expecting).

Finally, sometimes you just need to kill all eh* processes, and go into MCE again - that can be enough to get it working, if not, kill again, run QuickGuide, and try once more, and finally, reboot and try again - but I doubt this will really help.

Offline Shane

  • Senior Member
  • ****
  • Posts: 181
  • Vista Premium & Elgato EyeTV User
    • View Profile
    • shasam.net
Re: what weve been waiting for
« Reply #8 on: February 01, 2005, 10:06:50 PM »
OK - doh! I had the Channel ID in the ChannelInfo.XML file as the channel description rather than the "number" that signifies the channel ID.

I then had to go into settings and assign guide data to the channels (can't set same guide data to multiple channels though, ie 1 and 10).

The Sydney ChannelInfo.XML file is attached. With the categories file you posted in the other thread, this is pretty awesome... automatic series recording based on the EPG data... very cool (reminds me of the same fuction in Tivo's I've played with when in the US).

Regards,
Shane.

Offline BJReplay

  • Full Member
  • ***
  • Posts: 57
    • View Profile
Re: what weve been waiting for
« Reply #9 on: February 02, 2005, 10:05:40 AM »
Yeah, the documentation of ChannelInfo is rudimentary at best.

Offline Shane

  • Senior Member
  • ****
  • Posts: 181
  • Vista Premium & Elgato EyeTV User
    • View Profile
    • shasam.net
Re: what weve been waiting for
« Reply #10 on: February 03, 2005, 11:14:01 PM »
BJ,

Wondering if you are getting the same issue as me - When I get to the end of the available guide data (when the guide starts to report "No Data"), Channel Ten and SBS are looping, but not with their own data - Channel 10 for example starts to have Channel Seven data instead of "No Data" like the other channels.

Is this a config issue I have caused, a bug in the iceguide feed or something else?

Thanks,
Shane.

Offline BJReplay

  • Full Member
  • ***
  • Posts: 57
    • View Profile
Re: what weve been waiting for
« Reply #11 on: February 05, 2005, 02:38:04 PM »
At the moment I'm just calling the cgi direct to get the guide, rather than using a grabber, so I haven't seen this.

Offline Shane

  • Senior Member
  • ****
  • Posts: 181
  • Vista Premium & Elgato EyeTV User
    • View Profile
    • shasam.net
Re: what weve been waiting for
« Reply #12 on: February 11, 2005, 07:36:22 PM »
BJ,

What do you mean by pulling the CGI directly?

Regards,
Shane.

Offline BJReplay

  • Full Member
  • ***
  • Posts: 57
    • View Profile
Re: what weve been waiting for
« Reply #13 on: February 13, 2005, 05:42:14 PM »
Quote
BJ,

What do you mean by pulling the CGI directly?

Regards,
Shane.
I've got a build of QuickGuide that retrieves the guide directly (through code), rather than using webget.

However, I've seen the symptoms you mention - so I think it is a bug in the cgi or ice data - though it might also be a bug in QuickGuide.  Looking into it.

I'll let you know when I'm in a position to release a build of QuickGuide that retrieves the data direct from the icetv feed - but it won't be until there are user specific userids and password for the feed - and the ice people say it's ok to do - because otherwise it can be abused.

BJ.


Share via facebook Share via twitter

clip
What is this

Started by csutak40 on General Discussions

0 Replies
224 Views
Last post February 24, 2019, 09:22:29 PM
by csutak40
xx
What, exactly does the "This time" recording option do?

Started by prl on Smart Recording website and General questions

3 Replies
1081 Views
Last post February 08, 2019, 12:52:35 PM
by prl
xx
The Illusionists - what _is_ it about?

Started by prl on IceTV EPG Content

8 Replies
316 Views
Last post January 22, 2019, 07:00:37 PM
by prl
clip
What am I doing wrong?

Started by csutak40 on Smart Recording website and General questions

2 Replies
749 Views
Last post October 15, 2018, 07:07:47 PM
by csutak40