Author Topic: Quickguide Testing  (Read 4101 times)

Offline Shane

  • Senior Member
  • ****
  • Posts: 181
  • Vista Premium & Elgato EyeTV User
    • View Profile
    • shasam.net
Quickguide Testing
« on: February 02, 2005, 10:23:48 PM »
So far (after a few initial hurdles) everything is running well. Some things I have noticed are:

1. Cannot use the same channel data for different channels (ie "1" and "10")
2. Data for Channel 1 and SBS 1 in Sydney (not sure for Melb) seems to "loop" at the end of the 7 days. So if I go to that last days (just as it turns to no data available messages for 2, 7 & 9) Channel 10 and SBS data begins again with 7 day old data. Not sure if this is an ice issue or Quickguide (or me).
3. Need to make sure when you install that the facility to auto update the guide data in MCE is turned off (it is on by default). Not sure if this can be added to the registry hack or not.

I am also working on a batch file that will check for excess XML files and delete them before updating the data (otherwise we'll end up with a PC clogged with excess & redundant xml data). I'm going to try and ensure it checks for internet access first so it doesn't delete your guide data if there is no way to download more!

Then I'll put my install prpcedure together which may help with the install manual.

Regards,
Shane.
« Last Edit: January 01, 1970, 10:00:00 AM by shane »
Shuttle SB83G5M (P4 630 nVidia 6600) running Vista Premium with:
Hauppauge Nova-T 500 MCE Tuner|Ice TV Guide|PIMP|Buffalo LinkStation HD-H160LAN & HD-HG300LAN|Xbox 360 MCE

Offline Shane

  • Senior Member
  • ****
  • Posts: 181
  • Vista Premium & Elgato EyeTV User
    • View Profile
    • shasam.net
Re: Quickguide Testing
« Reply #1 on: February 03, 2005, 12:02:13 AM »
OK - here is my batch file. This makes the assumption that you copied all files & directories from the Quickguide Binaries folder, as well as the "webget.exe" file into the C:\Windows\ehome directory. The actual batch file is attached, but the contents are copied below.

You will need to replace the "<username>" and "<password>" with (you guessed it) your username and password for the icetv server. You will also need to change "icetvguide.xml" to the name of the XML file you have setup in QuickGuide.exe.config.

Regards,
Shane.

@ECHO OFF
CLS
PING server.icetv.info |FIND "TTL="
IF ERRORLEVEL 1 GOTO noconnect

:connect
ECHO You have an active connection to the Internet - EPG update proceeding
cd C:\WINDOWS\ehome\output
del *.xml
cd C:\WINDOWS\ehome\
webget http://server.icetv.info/cgi-bin2/xmlguide.cgi -u <username> -p <password> -o icetvguide.xml
quickguide /batch
goto end

:noconnect

ECHO Internet Connection not functional - EPG update aborted
goto end

:end
« Last Edit: January 01, 1970, 10:00:00 AM by shane »


Share via facebook Share via twitter

smiley
New QuickGuide Release

Started by BJReplay on Windows XP Media Center Edition

0 Replies
5231 Views
Last post June 01, 2005, 05:34:13 PM
by BJReplay
xx
New Batch files for Quickguide

Started by Shane on Windows XP Media Center Edition

1 Replies
4108 Views
Last post April 13, 2005, 08:27:21 PM
by Shane