Author Topic: PIMPmyMCE for Vista (version 2.02.00) ready for testing  (Read 23712 times)

Offline Daniel Hall at IceTV

  • Administrator
  • Guru
  • *****
  • Posts: 1216
    • View Profile
    • IceTV
PIMPmyMCE for Vista (version 2.02.00) ready for testing
« on: January 31, 2007, 02:55:32 PM »
The new PIMPmyMCE client (version 2.02.00) is now available as beta.

It can be downloaded from http://www.icetv.com.au/cgi-bin/downloads.cgi?op=get_file&number=13.

This version will only work on Vista MCE.

Fixes/Improvements:
  • Added fix for discSvc key changing after a guide download
  • Improved memory handling
  • Support added for Vista MCE
  • Support added for multiple PIMP devices

A new version will be available with any fixes that are relevant for Windows XP Media Center Edition 2005 once this version has been tested.

Please post any feedback below.
Regards,

Daniel.
CTO.

Offline Shane

  • Senior Member
  • ****
  • Posts: 181
  • Vista Premium & Elgato EyeTV User
    • View Profile
    • shasam.net
Re: PIMPmyMCE for Vista (version 2.02.00) ready for testing
« Reply #1 on: January 31, 2007, 06:15:42 PM »
Daniel (and team),

Installed and testing now (Vista 32bit). I have done a few guide downloads and so far so good. I've got some series recordings happening tonight so shall see how the padding goes.

Note: I've reversed impact's workaround (http://www.icetv.com.au/iceforum/index.php?topic=540.0) so I'll be watching for guide corruption now too.

Good work (for the moment - I'll update if otherwise) guys.

Regards,
Shane.
« Last Edit: February 01, 2007, 03:25:51 PM by Shane »
Shuttle SB83G5M (P4 630 nVidia 6600) running Vista Premium with:
Hauppauge Nova-T 500 MCE Tuner|Ice TV Guide|PIMP|Buffalo LinkStation HD-H160LAN & HD-HG300LAN|Xbox 360 MCE

Offline drokich

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: PIMPmyMCE for Vista (version 2.02.00) ready for testing
« Reply #2 on: February 01, 2007, 01:42:05 PM »
2.02.00 Beta didn't work for me unfortunetly, and yes I am running on Vista MCE. ICE sw installed OK, took my user ID and password OK and seemed to add EPG after going through the wizard once. But unfortunetly a channel was missing after my first scan and when I scanned again (I needed a second scan as channel 9 was missing) it had lost the EGP for all but channel 2.  It got worse as when I then tried to download EPG it now states that my country does not have EPG data, sigh.

I run the Start menu icon and re-insert my ICE user ID and password but MCE Vista still can not find any EPG for Australia :-(.

Offline Daniel Hall at IceTV

  • Administrator
  • Guru
  • *****
  • Posts: 1216
    • View Profile
    • IceTV
Re: PIMPmyMCE for Vista (version 2.02.00) ready for testing
« Reply #3 on: February 01, 2007, 02:49:11 PM »
Hi drokich,

Was this for Vista MCE x86 or Vista MCE 64-bit?

Offline drokich

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: PIMPmyMCE for Vista (version 2.02.00) ready for testing
« Reply #4 on: February 01, 2007, 03:58:16 PM »
I used Vista MCE x86, the MSDN version.

I am re-installing Home Pro Vista MCE now with a standard licenced to see if this helps. Once Vista is installed I will try ICE again.

Offline drokich

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: PIMPmyMCE for Vista (version 2.02.00) ready for testing
« Reply #5 on: February 01, 2007, 04:57:33 PM »
Sorry no go, the new Vista install does not download EPG via ICE either, on download in MCE is keeps saying :-
Discovery Service: Unsupported contry/region. Select Setup to configure the guide

Note: I have set all location settings in Vista to Australia.

Offline Daniel Hall at IceTV

  • Administrator
  • Guru
  • *****
  • Posts: 1216
    • View Profile
    • IceTV
Re: PIMPmyMCE for Vista (version 2.02.00) ready for testing
« Reply #6 on: February 01, 2007, 05:06:54 PM »
Hi drokich,

Have you installed and run the IceGuide4MCE setup program first before trying to setup the guide in Vista MCE?

I forgot to mention this above but the best method would be to follow the steps:


Offline drokich

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: PIMPmyMCE for Vista (version 2.02.00) ready for testing
« Reply #7 on: February 01, 2007, 07:55:57 PM »
It’s working Hooray.
It was an issue with assigning the EPG channels with the actual TV channel that caused me issues.  By default the TV channel name came up in the ICE supplied EGP list and I just left it on the default EPG name. But the actual EPG list had additional selections for the channels and if I select those it works (ie when assigning EPG to a channel use just "Nine" and do not use "Digital Nine").

Oh and as suggested I also installed IceGuide4MCE and reinstalled PIMPmyMCE client (version 2.02.00).

PS. You can use Dave in posts.  :)

Offline Leroy

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: PIMPmyMCE for Vista (version 2.02.00) ready for testing
« Reply #8 on: February 02, 2007, 03:33:41 PM »
This version worked for me on Vista Ultimate. Great stuff.

Offline Shane

  • Senior Member
  • ****
  • Posts: 181
  • Vista Premium & Elgato EyeTV User
    • View Profile
    • shasam.net
Re: PIMPmyMCE for Vista (version 2.02.00) ready for testing
« Reply #9 on: February 02, 2007, 06:17:15 PM »
Have to say - Vista Media Center is rock solid - with PIMP running with IceGuide, I've had no issues and no need for a reboot - MCE 2005 wasn't even running this well. The built-in HDTV decoder is working well too (so WinDVD, PowerDVD or Purevideo no longer required).

Sure I have some minor issues (folder duplication in Videos library the main one), but so far I'm honestly surprised at how well this has worked.

Regards,
Shane.

Offline helpware

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: PIMPmyMCE for Vista (version 2.02.00) ready for testing
« Reply #10 on: February 02, 2007, 11:31:37 PM »
Just installed it. Seems to be working well. Thanks guys!

Concerned a little by the large memory footpint (11.3 MB)

Rob



Offline Daniel Hall at IceTV

  • Administrator
  • Guru
  • *****
  • Posts: 1216
    • View Profile
    • IceTV
Re: PIMPmyMCE for Vista (version 2.02.00) ready for testing
« Reply #11 on: February 03, 2007, 12:07:45 AM »
Concerned a little by the large memory footpint (11.3 MB)

Thats after some cleanup actually, we are still checking for any more memory optimizations that can be done, but some of the initial builds were getting up to over 100MB used at times...

Offline saxnix

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: PIMPmyMCE for Vista (version 2.02.00) ready for testing
« Reply #12 on: February 03, 2007, 11:43:46 AM »
Hi, newbie Greg here,

I have loaded and assigned channels fine, but for the life of me I can't figure out how to use the Guide with keyboard and mouse???

Any suggestions would be great

PS Vista 32bit

Offline Shane

  • Senior Member
  • ****
  • Posts: 181
  • Vista Premium & Elgato EyeTV User
    • View Profile
    • shasam.net
Re: PIMPmyMCE for Vista (version 2.02.00) ready for testing
« Reply #13 on: February 03, 2007, 12:13:26 PM »
Here are the keyboard shortcuts for using Media Center with a keyboard. Hope it helps :)

Regards,
Shane.

Move up                                     UP ARROW
Move down                             DOWN ARROW
Move left                                LEFT ARROW
Move right                               RIGHT ARROW
Select                                          ENTER or SPACEBAR
Jump back one page at a time       PAGE UP
Jump ahead one page at a time      PAGE DOWN
Start Media Center                    Windows logo key+ALT+ENTER
Go back to the previous screen or backspace a single character in Search   BACKSPACE

Change to a specific channel        The number for the channel you want
Move up one channel                 EQUAL (=) or CTRL+EQUAL
Move down one channel               MINUS (-) or CTRL+MINUS

My TV            CTRL+SHIFT+T
My Music   CTRL+M
My Videos   CTRL+E
My Pictures   CTRL+I

Guide             CTRL+G
Record            CTRL+R
Details             CTRL+D
DVD Menu       CTRL+SHIFT+M
Recorded TV   CTRL+O
DVD Audio   CTRL+SHIFT+A
DVD Subtitle   CTRL+U

Pause             CTRL+P
Play              CTRL+SHIFT+P
Stop              CTRL+SHIFT+S
Replay             CTRL+B
Skip              CTRL+F
Rewind            CTRL+SHIFT+B
Fast Forward   CTRL+SHIFT+F
Mute              F8
Volume Down   F9
Volume Up   F10

Offline benaylen

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: PIMPmyMCE for Vista (version 2.02.00) ready for testing
« Reply #14 on: February 03, 2007, 02:33:34 PM »
Have spent half a day mucking around with this and still no luck. Most drastic attempt so far involved uninstalling PIMP, deleting all channels in MCE, restoring defaults in guide settings, rebooting, installing IceTV, then PIMP beta, then running guide setup and still getting "Unsupported contry/region. Select Setup to configure the guide". I can't get the IceTV bit up in MCE at all not even with sample guide data. I think drokich fluked it  :) Any ideas short of re-installing Vista?

My plan was to get the guide working they way I want so I could run the MCUpdate fix (disabling the service) as per http://www.icetv.com.au/iceforum/index.php?topic=540.0 but that's no good to me if I can't get Vista to talk to IceTV at all.

Ben

Gigabyte H663 HTPC running Vista Ultimate


Share via facebook Share via twitter