Author Topic: Guide Not Downloading  (Read 6012 times)

Offline kand8979

  • Junior Member
  • **
  • Posts: 13
    • View Profile
Guide Not Downloading
« on: March 29, 2007, 10:42:23 PM »

Using Latest version of PIMP in Vista and the guide is not downloading.

The connection works, the test works, but when I tell it to download the MediaCenter Icon sits in the taskbar and stays at 0%.

Been like this for over a week now.

Tried uninstalling and reinstalling, clearing all the channels and rescanning.

Very frustrated at this point.  Anybody have any suggestions?

Offline Russell at IceTV

  • Guru
  • *****
  • Posts: 444
    • View Profile
Re: Guide Not Downloading
« Reply #1 on: March 30, 2007, 01:10:02 AM »
Hi,

Well, this is a weird one...  Looking at the server logs, I can see that your MCE is definitely connecting to the server and requesting the guide file, but apparently it's sending a "conditional" request, which basically is like saying, "Give me the guide file but only if it's changed since 'this' date."  That happens fairly often in the logs from lots of different MCEs actually.  I guess MCE is smart enough to only download the guide if something's changed since the last time.  But I don't really know why it's doing a conditional request in this case, since it's clearly not liking the answer it's getting, and hanging at 0%.

I'm thinking you might need to reset MCE and basically start over with the guide setup.  To do that, go to Tasks / Settings / TV / Guide / Set Up Guide Listings, and follow through the wizard.  When you get to "Do you want to use the guide?", set it to No and finish the wizard.  Then go back through the same wizard again and answer "Yes" to the same question, and set it up again from scratch.  I'm hoping that MCE will kind of "start over" and maybe not get confused this time.

Note that the "Set Up Guide Listings" option is not available in the list of menu choices when you're connecting via Remote Desktop so be sure you're at the computer.

Also, after resetting everything, it's possible that you might end up with a new "ID number", which needs to be registered again with the IceTV server, so it knows who you are.  If it ends up only downloading channel ABC with demo data, run the IceGuide4MCE.exe setup program again, and then tell MCE to do a manual guide update with the "Get Latest Guide Listings" option, and hopefully it should work ok.

Russell

Offline kand8979

  • Junior Member
  • **
  • Posts: 13
    • View Profile
Re: Guide Not Downloading
« Reply #2 on: March 30, 2007, 04:32:28 PM »
OK So I tried this, went through the wizard first time and told it No to "Do you want to use the guide?".

Then closed Media Center Opened again and ran through the wizard saying yes, when it goes to download the data I get an error
"File Validation Error - Mismatch Guide Package Code 21"  Tried Rebooting, same error.

So then I reran IceGuide4MCE and now MCE Tells me no guide data is available for my region.

Suggestions?!



Offline kand8979

  • Junior Member
  • **
  • Posts: 13
    • View Profile
Re: Guide Not Downloading
« Reply #3 on: April 01, 2007, 03:09:12 PM »
Well still not working and I don't know what else to try.

Clearly though the uninstall is not working completely as when I reinstall PIMP it has remembered all my settings, username password PIMP Device.

I went looking for a file to delete but not sure where it would be.

And no re-installation is not an option as this is my main PC.

Luckily I have a Topfield 5000 which works perfectly.

Offline Daniel Hall at IceTV

  • Administrator
  • Guru
  • *****
  • Posts: 1216
    • View Profile
    • IceTV
Re: Guide Not Downloading
« Reply #4 on: April 02, 2007, 11:40:41 AM »
The PIMP settings are all kept in the registry, but they should be fine.

The best course now would be to go through the guide setup as Russell posted above and choose not to use the guide, then ensure that PIMP is not running and delete all the cache files manually that Vista MCE uses. To do this go to C:\ProgramData\Microsoft\eHome\EPG\ and delete all the files and folders in this directory (the folders will be called 'prefs' and 'tracehelper'), don't worry if one or two files cannot be deleted.

Then re-run the PIMP client and make sure that all the settings are correct, run the guide setup from within Vista MCE. If you receive the error saying that "There are no guide listings for your country/region" then minimize the MCE screen (but leave it running on that error) and go into the PIMP client and click the "Fix Now" button on the "Configuration" tab, this will fix the settings straight away. Go back into the MCE screen and click "Back" and then "Next" to have it try again and this time it will go through.
Regards,

Daniel.
CTO.

Offline kand8979

  • Junior Member
  • **
  • Posts: 13
    • View Profile
Re: Guide Not Downloading
« Reply #5 on: April 07, 2007, 07:44:47 PM »
Daniel

Thanks for that, I tried what you suggested and it has made no difference.

The guide still refuses to download and gives me the error about Mismatch Data.

No TV Guide for Vista through ICE.


Offline kand8979

  • Junior Member
  • **
  • Posts: 13
    • View Profile
Re: Guide Not Downloading
« Reply #6 on: April 07, 2007, 08:23:57 PM »
OK so I have tried a couple of the "other" TVGuide solutions and this is what I have come up with.

Installing/Uninstalling ICE over the last few weeks has broken Vista MCE Guide Functionality on my pc.  I know that is a big accusation but it is the only thing that makes any sense to me at this point.

I am continually getting error code 21 no matter what I do or try, there is probably some obscure registry setting that needs to be adjusted to fix this but I don't know what it is and I have no intention of reinstalling Vista on this machine so it will stay broken.

I have to say this whole thing has left a very sour taste in my mouth, the whole reason I subscribe to ICE is so I don't have to screw around with installing software and tweaking settings to get a TV guide. >:(


Offline IceJason

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: Guide Not Downloading
« Reply #7 on: April 08, 2007, 07:46:05 PM »
The PIMP settings are all kept in the registry, but they should be fine.

The best course now would be to go through the guide setup as Russell posted above and choose not to use the guide, then ensure that PIMP is not running and delete all the cache files manually that Vista MCE uses. To do this go to C:\ProgramData\Microsoft\eHome\EPG\ and delete all the files and folders in this directory (the folders will be called 'prefs' and 'tracehelper'), don't worry if one or two files cannot be deleted.

Then re-run the PIMP client and make sure that all the settings are correct, run the guide setup from within Vista MCE. If you receive the error saying that "There are no guide listings for your country/region" then minimize the MCE screen (but leave it running on that error) and go into the PIMP client and click the "Fix Now" button on the "Configuration" tab, this will fix the settings straight away. Go back into the MCE screen and click "Back" and then "Next" to have it try again and this time it will go through.

Thank you very much Daniel for that fix, worked a charm with one of the first stubborn problems I have not been able to rectify on my own.
 ;D


Share via facebook Share via twitter

xx
Changing Guide Region

Started by Trial_Master on General Discussions

2 Replies
174 Views
Last post June 23, 2019, 06:40:28 PM
by Trial_Master
xx
Account guide settings

Started by simoncasey on IceTV EPG Content

24 Replies
405 Views
Last post June 19, 2019, 05:35:32 PM
by Daniel Hall at IceTV
xx
Plex Setup Instructions - Enhanced Guide setting & frequent program refreshes

Started by Peter_H on Plex

4 Replies
286 Views
Last post April 19, 2019, 06:13:23 PM
by Peter_H
xx
Channels not showing guide data

Started by schmitty on IceTV EPG Content

1 Replies
353 Views
Last post October 04, 2018, 09:20:08 AM
by Daniel Hall at IceTV