Author Topic: Windows 7 RC - Channel scanning issue  (Read 6160 times)

Offline skasey

  • Newbie
  • *
  • Posts: 2
    • View Profile
Windows 7 RC - Channel scanning issue
« on: May 09, 2009, 03:43:46 PM »
Hi, and thanks for providing a beta program for Windows 7.

I've done some testing this weekend and found an issue when scanning for channels AFTER downloading the EPG via the method described in the sticky.

I have Windows 7 RC (build 7100) clean install with a Hauppauge HVR-2200 card installed. On my first build, after completing the Windows install I ran the webget batch BEFORE setting up or even opening Media Centre. The EPG download was successful however I then ran through the Media Centre setup and when trying to scan for channels (Melbourne) it does not detect any of the 24 channels. I tried deleting a number of files in the ProgramData\eHome folder (as a previous post suggested) however this had no effect. No channels could be detected.

I then reinstalled Windows exactly the same as previously but this time completed the Media Centre setup process BEFORE running the batch file. Media Centre this time picked up all 24 channels without a problem and the batch file once again ran fine. On returning to Edit Channels I found all of the -icetv labels to be correct and everything now works fine.

It would seem that the beta EPG download perhaps changes something or applies a setting to do with regional settings which causes Media Centre to be unable to use the postcode you provide to then find channels in your area. Not sure if this has been reported before so appologies if this is covered

Thanks again!


Offline Daniel Hall at IceTV

  • Administrator
  • Guru
  • *****
  • Posts: 1285
    • View Profile
    • IceTV
Re: Windows 7 RC - Channel scanning issue
« Reply #1 on: May 11, 2009, 03:16:48 PM »
This definitely sounds like the same issue as http://www.icetv.com.au/iceforum/index.php?topic=1797.0

Actually just looking through the sticky and it doesn't specify when to scan in the channels, maybe a note should be added that it should be done prior to the setup of the IceTV guide.
Regards,

Daniel.
CTO.

Offline skasey

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Windows 7 RC - Channel scanning issue
« Reply #2 on: May 12, 2009, 09:45:48 PM »
Yes, it's exactly the same problem however the solution offered did not resolve the problem.

I think adding a note in the sticky would definately help others. Typically people may be installing Windows 7 a fresh and trying to install the EPG immediately following. Took me an hour or so to realise what was happening.

Offline dgaust

  • Senior Member
  • ****
  • Posts: 85
    • View Profile
Re: Windows 7 RC - Channel scanning issue
« Reply #3 on: May 13, 2009, 10:15:14 AM »
You should be able to fix errors using the following steps.

1. Close the Media Center UI/Shell (ehshell.exe)
2. Open an Administrator Command Prompt (launch Command Prompt with ‘run as Administrator’ option).
3. In the Command prompt - Change to the root ‘ehome’ directory (ie. c:\windows\ehome)
4. Run the mcupdate.exe command with the parameter ‘-MediaCenterRecoveryTask’
Ie. mcupdate.exe -MediaCenterRecoveryTask
5. Start the Media Center UI – and reconfigure your Media Center system.

Offline mitty

  • Newbie
  • *
  • Posts: 9
    • View Profile
Re: Windows 7 RC - Channel scanning issue
« Reply #4 on: May 13, 2009, 02:43:04 PM »
Not an ICEtv issue, but has anyone else noticed it's a painfully long process to scan in your channels.  Also if adding another tuner you have to go through the entire rigmarole again (when the existing tuning info should be enough to get a new tuner going).  Has anyone found anyway around this?

Offline SOULVISITOR

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Windows 7 RC - Channel scanning issue
« Reply #5 on: June 01, 2009, 10:35:34 PM »
yup got me too...
Dont install Ice TV, before running MCE setup in Win7RC (Haumpage? 2200), I noticed it changes the tuner type, once you do the fix on this page and all is well again. cheers


Share via facebook Share via twitter

xx
WMC running in Windows 10 but IceTV not recording

Started by dataplex on Windows 8 Media Center

2 Replies
1040 Views
Last post January 12, 2019, 07:05:54 PM
by dataplex
xx
More Windows 10 updates eating WMC

Started by Dave on Windows 8 Media Center

0 Replies
986 Views
Last post March 20, 2018, 01:35:41 PM
by Dave
xx
Windows 10 Anniversary Update ate my WMC!

Started by a4x4kiwi on Windows 8 Media Center

12 Replies
6237 Views
Last post July 23, 2019, 04:13:34 PM
by raymondjpg
clip
Windows 10 Grrr

Started by csutak40 on XMLTV (General)

5 Replies
3277 Views
Last post July 23, 2016, 01:42:10 PM
by IanL-S