Author Topic: What have I missed?  (Read 7345 times)

Offline csutak40

  • Guru
  • *****
  • Posts: 1116
    • View Profile
What have I missed?
« on: November 01, 2009, 07:57:02 PM »
I am rather late setting all this up, my PC was down.

I realise that this probably doesn't belong here, but I thought someone here may have the same settings.  I got an email from John, with instructions to change the IceGuide.ini and the TS.ini.  He said: You need to edit IceGuide.ini rather than Central.ini. Instead of adding 7TWO^72 you must add nnn^72 where ‘nnn’ is the unique number that IceTV assigns to channel 7TWO in their data.  So, I phoned IceTV and was told that the number for Melbourne is 2397.  So, I changed it to that, ran TED+ - nothing!

I am sure other things need to be changed, but my set up is so complicated I never remember what to do from one time to the next.  Just recently someone told me to check one of the ini files, and becaue SBS2 wasn't working properly and sure enough, I had it wrong.  Don't remember which Forum this was on.  Just spent half an hour attempting to find that thread - couldn't.

I have the various things I'm using in my sig - hoping that someone here can tell me what I did wrong
Cheers,
Judy
Windows 7 Media Center; Last Update Feb 20 2006; Beyonwiz T4, T2

Offline tonymy01

  • Guru
  • *****
  • Posts: 740
    • View Profile
Re: What have I missed?
« Reply #1 on: November 01, 2009, 08:16:04 PM »
Have you got 7TWO ticked on in your profile?
Regards
Tony

Beyonwiz DP-S1 & Topfield 5K (using PerlTGD to upload ICE EPG/timers for the 5K, normal ICE interactive for the Wiz).

Offline Gary

  • Senior Member
  • ****
  • Posts: 155
    • View Profile
Re: What have I missed?
« Reply #2 on: November 01, 2009, 09:30:03 PM »
Have you edited TS.ini as well?

Offline csutak40

  • Guru
  • *****
  • Posts: 1116
    • View Profile
Re: What have I missed?
« Reply #3 on: November 01, 2009, 09:49:18 PM »
Have you got 7TWO ticked on in your profile?
If you mean on "Show on IceTV website" then yes.

Offline csutak40

  • Guru
  • *****
  • Posts: 1116
    • View Profile
Re: What have I missed?
« Reply #4 on: November 01, 2009, 09:49:39 PM »
Have you edited TS.ini as well?

Yes, I did

Offline csutak40

  • Guru
  • *****
  • Posts: 1116
    • View Profile
Re: What have I missed?
« Reply #5 on: November 02, 2009, 05:32:47 PM »
I had another look at TEDS+  No idea what that means, but  7TWO appears in the list of channels in favourites, but not in the programme guide.

Here is a copy of the altered bit in the ini files - in case I am missing something by staring at it too long. :P

Channel.Conversions=9^2|36^22|6^7|7^9|2397^72|8^10|10^3|32^32|90^20|91^90|92^30|93^70|94^1|1697^12|2390^99

and TS.ini

[ChannelInfo]
ID1=ABC1,2,+
ID2=ABC2,22,+
ID3=Seven,7,+
ID4=Nine,9,+
ID5=TEN,10,+
ID6=SBS 1,3,+
ID7=SBS 2,32,+
ID8=ABC HD,20,+,HD
ID9=Nine HD,90,+,HD
ID10=SBS HD,30,+,HD
ID11=7HD,70,+,HD
ID12=TEN HD,1,+,HD
ID13=GO!,99,+
ID14=7TWO,72,+


I also changed  epg_upload.ini (although not sure if I was meant to)  I am attaching the whole list, because I simply added 7TWO, but the rest don't actually make too much sense to me

Number of Services=20


[TV Parameters]

[Channel 1]
service_name=TGDChannelID
service_id=0
transport_stream_id=0
original_network_id=0

[Channel 2]
service_name=TGDChannelID
service_id=0
transport_stream_id=0
original_network_id=0

[Channel 3]
service_name=TGDChannelID
service_id=0
transport_stream_id=0
original_network_id=0

[Channel 4]
service_name=TGDChannelID
LCN_channel=656802084

[Channel 5]
service_name=TGDChannelID
LCN_channel=1868982636

[Channel 6]
service_name=1
LCN_channel=1

[Channel 7]
service_name=2
LCN_channel=2

[Channel 8]
service_name=3
LCN_channel=3

[Channel 9]
service_name=7
LCN_channel=7

[Channel 10]
service_name=9
LCN_channel=9

[Channel 11]
service_name=10
LCN_channel=10

[Channel 12]
service_name=20
LCN_channel=20

[Channel 13]
service_name=22
LCN_channel=22

[Channel 14]
service_name=33
LCN_channel=33

[Channel 15]
service_name=70
LCN_channel=70

[Channel 16]
service_name=90
LCN_channel=90


[Channel 17]
service_name=30
LCN_channel=30

[Channel 18]
service_name=32
LCN_channel=32

[Channel 19]
service_name=99
LCN_channel=99

[Channel 20]
service_name=72
LCN_channel=72




Offline Gary

  • Senior Member
  • ****
  • Posts: 155
    • View Profile
Re: What have I missed?
« Reply #6 on: November 02, 2009, 06:29:27 PM »
I just checked by getting the xml data for myself and 7TWO is 2405 not 2397 so that will be your problem.

Always better to grab it for yourself and get it right. :)

Offline csutak40

  • Guru
  • *****
  • Posts: 1116
    • View Profile
Re: What have I missed?
« Reply #7 on: November 02, 2009, 06:44:11 PM »
I just checked by getting the xml data for myself and 7TWO is 2405 not 2397 so that will be your problem.

Always better to grab it for yourself and get it right. :)

Where do you get it from?

You are in Melbourne, right?  ;D
« Last Edit: November 02, 2009, 06:45:56 PM by csutak40 »

Offline Gary

  • Senior Member
  • ****
  • Posts: 155
    • View Profile
Re: What have I missed?
« Reply #8 on: November 02, 2009, 06:48:57 PM »
I just checked by getting the xml data for myself and 7TWO is 2405 not 2397 so that will be your problem.

Always better to grab it for yourself and get it right. :)

Where do you get it from?

You are in Melbourne, right?  ;D
Yes I am in Melbourne and I got it from the same place TED gets all its nformation - IceTV.

Have a look at this

http://www.icetv.com.au/cgi-bin/websupport.cgi?op=show_faq&faq_id=53&faq_cat_id=2

Offline tonymy01

  • Guru
  • *****
  • Posts: 740
    • View Profile
Re: What have I missed?
« Reply #9 on: November 02, 2009, 08:15:29 PM »
I have explained a few times, you don't need to download the XML to find out your number, simply go to your account page where you get to tick on/off the various channels, then view the source of the webpage, and you will see it down a bit when you start finding the html info in the source related to the section where you tick on/off the channels.   

Please don't edit your EPG_uploader.ini file (please!).   When it finds a new LCN in the source data, it will add it automatically.

Offline csutak40

  • Guru
  • *****
  • Posts: 1116
    • View Profile
Re: What have I missed?
« Reply #10 on: November 02, 2009, 08:26:21 PM »

Yes I am in Melbourne and I got it from the same place TED gets all its nformation - IceTV.

Have a look at this

http://www.icetv.com.au/cgi-bin/websupport.cgi?op=show_faq&faq_id=53&faq_cat_id=2

Thank you very much for that.  That solved part of the problem.  I am now very confused (for a change :-[)  Ran TED+ again, now have all the channels, but the timers aren't uploading to the Toppy.  What's even weirder is that it has populated JustEPG with the 7TWO programs, (well, mostly "coming soon" :P) so TED must be talking to the Toppy, but no timers  ???  :'(

Offline Gary

  • Senior Member
  • ****
  • Posts: 155
    • View Profile
Re: What have I missed?
« Reply #11 on: November 02, 2009, 08:36:20 PM »
I have explained a few times, you don't need to download the XML to find out your number, simply go to your account page where you get to tick on/off the various channels, then view the source of the webpage, and you will see it down a bit when you start finding the html info in the source related to the section where you tick on/off the channels.   
You are correct of course but my way was how I first got them so it stuck.

Offline csutak40

  • Guru
  • *****
  • Posts: 1116
    • View Profile
Re: What have I missed?
« Reply #12 on: November 02, 2009, 11:50:40 PM »


Please don't edit your EPG_uploader.ini file (please!).   When it finds a new LCN in the source data, it will add it automatically.


Oops!  OK, I put it back the way it was.  Hope that's all that's wrong.  Will see what happens tomorrow

P.S.  Decided not to wait until tomorrow, ran TED+ again, still didn't upload to the Toppy  :'(

Offline tonymy01

  • Guru
  • *****
  • Posts: 740
    • View Profile
Re: What have I missed?
« Reply #13 on: November 03, 2009, 12:00:36 AM »
But does it find any?  You probably don't need to delete that line now you added it, it is just that LCN info is automatic, you don't need to change anything on the Toppy.   As long as you have a 72 in the Toppy, and TED is creating TGDs with "72" in them for the timers/EPG, then all should be well.   So is it?
What do the logs of TED/S and EPG_uploader show, EPG_uploader would have logs showing timer failed if TED is sending them with incorrect info?  Do you see any fails when you upload and the TAP loads the timer file?  The TAP has a popup/banner at the end to show success/fail/deleted.
Oh, and did you restart your Toppy since you scanned for new channels (EPG_uploader maps out your channels from 0 to whatever you have stored against their LCNs, if you add any new LCNs while the TAP is running, it may not notice it and so give channel errors in the logs as it can't find any "LCN72" in the stored table it builds when it loads).
« Last Edit: November 03, 2009, 12:06:39 AM by tonymy01 »

Offline csutak40

  • Guru
  • *****
  • Posts: 1116
    • View Profile
Re: What have I missed?
« Reply #14 on: November 03, 2009, 04:48:47 PM »
But does it find any?  You probably don't need to delete that line now you added it, it is just that LCN info is automatic, you don't need to change anything on the Toppy.   As long as you have a 72 in the Toppy, and TED is creating TGDs with "72" in them for the timers/EPG, then all should be well.   So is it?
What do the logs of TED/S and EPG_uploader show, EPG_uploader would have logs showing timer failed if TED is sending them with incorrect info?  Do you see any fails when you upload and the TAP loads the timer file?  The TAP has a popup/banner at the end to show success/fail/deleted.
Oh, and did you restart your Toppy since you scanned for new channels (EPG_uploader maps out your channels from 0 to whatever you have stored against their LCNs, if you add any new LCNs while the TAP is running, it may not notice it and so give channel errors in the logs as it can't find any "LCN72" in the stored table it builds when it loads).

Well...  To answer the last question first, yes I did restart the Toppy (and even the computer, to be on the safe side) several times.  Yesterday, the ini file did not find a new entry.  After several tries, I decided to sleep on it and let it run at the time it normally does (4pm)  It was mostly a success. I should have (forgot) checked the ini file if it has changed before it ran.  It has now generated a new entry.  BTW, just noticed, there is another in file: epg_uploadTED.ini  (in IceBox2) - that one doesn't seem to have an entry for either Go! or the new 7TWO, so it may be an old file no longer in use?

Anyway, it did upload to the Toppy, BUT, it didn't include some things that the log file indicates it should have.  It showed some errors, but that is quite probably because there are too many timers listed. The one I was looking for (didn't check all of them) was UglyBetty, which of course is on the new 7TWO, even though the log shows that will be recorded.  It also hasn't deleted quite a few shows that I have marked to be deleted, for various reasons.

(+) **    [P] 7TWO...... (OT) Tu 2009-11-03  19:27 20:45  (-03 +15)  Ugly Betty

Had a quick look - not one timer is set for 7TWO, which may or may not be a co-incidence
Looks like I will have to do what I hate doing (sometimes I end up with no timers for days) that is manually delete all the timers and go back to square one.

Here is the log

Nov 3, 16:05:11 : TED+ v7.10.1.512 started
- Registered to Judy Bednar. Expires 5 Dec 2010.
Nov 3, 16:05:12 : Getting EPG data (IceGuide)...
Nov 3, 16:05:21 : Producing EPG datafiles...
Nov 3, 16:05:58 : Checking for missing data...
Nov 3, 16:05:59 : Searching for Favourites...
- WARNING! Timer failure detected... check Timers Log
Nov 3, 16:08:29 : Processing Timers...
- AutoResolved Timer clashes... check Timers Log
Nov 3, 16:08:31 : Transferring Timers to Topfield
Nov 3, 16:08:34 : Transferring EPG data to Topfield...
Nov 3, 16:09:22 : Producing TV Guide data...
Nov 3, 16:09:26 : Finished... opening LOG Report.
Nov 3, 16:12:28 : Retrieving current Toppy Timers...
- WARNING! Timer processing failure detected... check Timer Processing Report
- WARNING! Timers Sync Check failed... check Timer Processing Report
Nov 3, 16:19:44 : FINISHED.


Share via facebook Share via twitter

clip
What is this

Started by csutak40 on General Discussions

0 Replies
242 Views
Last post February 24, 2019, 09:22:29 PM
by csutak40
xx
What, exactly does the "This time" recording option do?

Started by prl on Smart Recording website and General questions

3 Replies
1133 Views
Last post February 08, 2019, 12:52:35 PM
by prl
xx
The Illusionists - what _is_ it about?

Started by prl on IceTV EPG Content

8 Replies
370 Views
Last post January 22, 2019, 07:00:37 PM
by prl
clip
What am I doing wrong?

Started by csutak40 on Smart Recording website and General questions

2 Replies
803 Views
Last post October 15, 2018, 07:07:47 PM
by csutak40