Author Topic: A problem with.....  (Read 2355 times)

Offline csutak40

  • Guru
  • *****
  • Posts: 1109
    • View Profile
A problem with.....
« on: November 08, 2010, 05:00:16 PM »
OK. I honestly don't know where the problem is.  To start at the end, I just noticed that Chl 31 has finally made an appearance on the widget, so this made me wonder if this could upset other settings?

Now, to tell you my problem.  I use TED and JustEPG.  Yesterday, after TED ran at the scheduled time, I got "No EPG data found in ICE Files" when I attempted to open JustEPG.  I also noticed an EPG_Uploader error, that I wasn't quick enough to read.  So, I opened the log and (among other things) I found this consistent message "Can't open file!!: "20101109.tgd" and "Can't find inifile service_id:0 LCN:0 for any Topfield channels"

I haven't touched any ini files in anything for ages (not since the appearance of GEM and 7Mate) BTW

As usual, this is all Greek to me.  I tried rebooting (including a hard reset) re-running TED, several times, and as I was having some pixelation problems with ABC on the Toppy only earlier in the day, even tried re-scanning.  I have written to both Toppy forums (although it seems no one frequents the UK one any longer and still waiting for the moderator's approval on the "new" Forum), but now that I have noticed the Chnl 31 appearing on the widget I wonder if this has something to do with the problem.  I will now attempt to change the various ini files to show Chnl 31, but just thought I'd write here, to see if anyone would have any idea, especially as I know that Tony does read this Forum.  :P
Cheers,
Judy
Windows 7 Media Center; Last Update Feb 20 2006; Beyonwiz T4, T2

Offline tonymy01

  • Guru
  • *****
  • Posts: 740
    • View Profile
Re: A problem with.....
« Reply #1 on: November 08, 2010, 11:05:22 PM »
:-)
Might have to get back to you on this one... bump it in a couple of days time.
Regards
Tony

Beyonwiz DP-S1 & Topfield 5K (using PerlTGD to upload ICE EPG/timers for the 5K, normal ICE interactive for the Wiz).

Offline csutak40

  • Guru
  • *****
  • Posts: 1109
    • View Profile
Re: A problem with.....
« Reply #2 on: November 10, 2010, 12:58:48 PM »
:-)
Might have to get back to you on this one... bump it in a couple of days time.

Well, firstly, seems my poltergeist had a go again!  Even before asking for help, I looked at the justEPG.ini and it looked fine to me.  Then decided to compare it to the last version I saved.  I discovered that  it had "JustSource=2" whereas the original had "JustSource=1"  1 being TGD Files, 2=ICE Files.  My logic (such as it is  ;D) would say that 2 should be correct and I certainly haven't changed, or even looked at it since I added the new channels to the second page, I thought I'd try changing it to 1 and Voila! it was fixed!  ???

So, my original problem is fixed.  However, as I noticed all these error messages on the epg_upload.ini, decided to look at the log again, after justEPG got fixed.  Still had errors.

2010/11/10 11:03:44-EPG Uploader3.26beta6 FWrevision from extap-416:1248, from firebirds firbirdlib-416:1248
2010/11/10 11:03:44-Flash GMT Offset Detected: 660 minutes
2010/11/10 11:03:45-Sun Apr  3 02:59:59 2011 EST GMToffset:660mins DST
2010/11/10 11:03:46-ERROR:Can't find inifile service_id:0 LCN:0 for any Topfield channels
2010/11/10 11:03:46-ERROR:Can't find inifile service_id:0 LCN:0 for any Topfield channels
2010/11/10 11:03:46-ERROR:Can't find inifile service_id:0 LCN:0 for any Topfield channels
2010/11/10 11:03:46-ERROR:Can't find inifile service_id:0 LCN:656802084 for any Topfield channels
2010/11/10 11:03:46-ERROR:Can't find inifile service_id:0 LCN:1868982636 for any Topfield channels
2010/11/10 11:03:47-EITBLOCK return:0
2010/11/10 11:03:47-exTAP_GetUTCTime returned:0
2010/11/10 11:03:47-TDT_UTC:mjd:d8d6 00:04
2010/11/10 11:03:48-could not open GMT TZfile in /ProgramFiles/zoneinfo DIR
2010/11/10 11:03:48-could not open posixrules TZfile in /ProgramFiles/zoneinfo DIR
2010/11/10 11:03:49-Determining GMT offset and manual time is currently 0xd8d6 11:03:48
2010/11/10 11:03:49-Setting Flash UTCOffset to:660mins
2010/11/10 11:03:49-Setting GMTbugfix Time to 0xd8d6 00:04GMT
2010/11/10 11:03:49-making epg guide stick at Location:80120994
2010/11/10 11:03:49-Setting NOP to GMT update code, orig instruction 0xaf8284c4
2010/11/10 11:03:49-Current event RAM Short:640000bytes Extended:1280000bytes
2010/11/10 11:03:49-New event RAM Short:960000bytes Extended:1920000bytes
2010/11/10 11:03:50-AutoLoad is ON, deleting/adding files
2010/11/10 11:03:50-entered file delete: 11:03H
2010/11/10 11:03:50-EPG EIT Erase entered
2010/11/10 11:04:05-Number of timers changed, saving epg_timers.tsv file
2010/11/10 11:08:50-Regular file delete and check-
2010/11/10 11:08:50-entered file delete: 11:08H
2010/11/10 11:13:50-Regular file delete and check-
2010/11/10 11:13:50-entered file delete: 11:13H
2010/11/10 11:18:50-Regular file delete and check-
2010/11/10 11:18:50-entered file delete: 11:18H
2010/11/10 11:23:50-Regular file delete and check-
2010/11/10 11:23:50-entered file delete: 11:23H


So, I did some fiddling with the channels in the ini file, but thought I'd run it past you before uploading it, as it is only guesswork on my part, no idea what I'm doing, so would hate to break it.

[General]

USE_GMT_OffsetFILE=GMT:TAPOffset
TZ=Australia/Melbourne
GMT_Offset=44
Frequency File check No Timeshift=720
Frequency File check Timeshift=5
Email Volume=OFF
AutoLoadEPGdata=YES
AutoDeleteEPGdata at start=YES
Next Update Time=-1
Reload Hour=16
Load Number of Days=7
TGD directory=/EPGdata
Display LOADING OSD=MINIMAL
Logging Level (4everything 0nothing)=3
Broadcaster EIT=BLOCK
EPG load wait=3
Timer Set Delay=350
TEDS Recordings File=YES
ToppybiffTransparency=255
Scan ALL Events=NO
Load Short Events=NO
Set Manual Time at Startup=YES
Set Manual Time at power fail=YES
Manual Time GMT FIX=YES
Adjust GMT loading entries=YES
Set Manual Time on LCNs=002,003,021,022
Exit Key for Menu=YES
LCN TGD load=YES
Number of Services=23


[TV Parameters]


[Channel 1]

service_name=1
LCN_channel=1


[Channel 2]

service_name=2
LCN_channel=2


[Channel 3]

service_name=3
LCN_channel=3


[Channel 4]

service_name=7
LCN_channel=7


[Channel 5]

service_name=9
LCN_channel=9


[Channel 6]

service_name=10
LCN_channel=10


[Channel 7]

service_name=20
LCN_channel=20


[Channel 8]

service_name=22
LCN_channel=22


[Channel 9]

service_name=33
LCN_channel=33


[Channel 10]

service_name=70
LCN_channel=70


[Channel 11]

service_name=90
LCN_channel=90


[Channel 12]

service_name=30
LCN_channel=30


[Channel 13]

service_name=32
LCN_channel=32


[Channel 14]

service_name=99
LCN_channel=99


[Channel 15]

service_name=72
LCN_channel=72


[Channel 16]

service_name=12
LCN_channel=12


[Channel 17]

service_name=73
LCN_channel=73


[Channel 18]

service_name=44
LCN_channel=44

« Last Edit: November 10, 2010, 01:01:12 PM by csutak40 »

Offline tonymy01

  • Guru
  • *****
  • Posts: 740
    • View Profile
Re: A problem with.....
« Reply #3 on: November 10, 2010, 02:10:23 PM »
You could have purged all bar 1 channel, and epg uploader  will build them automatically as it detects the lcn channel numbers in the tgd files.  That justepg option is for  native icebox files, not tgd files.  As per your error log, you are missing key files for the timezone stuff, they are in the tap zip file, and need to be installed for the dst stuff to work.


Share via facebook Share via twitter

xx
Shaun Micallef is Mad As Hell

Started by prl on IceTV EPG Content

12 Replies
48 Views
Last post July 19, 2019, 07:39:59 AM
by prl
xx
A Current Affair Wednesday

Started by csutak40 on IceTV EPG Content

1 Replies
75 Views
Last post July 11, 2019, 03:11:01 PM
by grumpy_geoff
question
Program thumbnails

Started by bowser on IceTV EPG Content

0 Replies
86 Views
Last post July 06, 2019, 03:13:28 PM
by bowser
xx
Seal Team

Started by gsmith2409 on IceTV EPG Content

1 Replies
73 Views
Last post July 03, 2019, 08:59:09 PM
by Tiphanee