IceTV Forum

IceTV Guide for IceTV enabled PVRs => Beyonwiz => Topic started by: IanL-S on April 15, 2020, 07:57:15 AM

Title: Same program recorded 8 times on T2 (NOT IceTV issue)
Post by: IanL-S on April 15, 2020, 07:57:15 AM
Last night my T2 recorded the Mentalist 8 times - all starting at the same time. Never seen anything like it before. Anyone else have this problem? WHoops, just noticed everything recorded multiple times yesterday. Other T2 did not exhibit this problem (fortunately).

Ian
Title: Re: Same program recorded 8 times on T2
Post by: prl on April 15, 2020, 08:26:50 AM
Are there multiple timers for The Mentalist that recorded 8 times?
Title: Re: Same program recorded 8 times on T2
Post by: IanL-S on April 15, 2020, 09:42:37 AM
Excellent question - I had not checked! No, no multiple timers.

I have attached an Excel file listing the files for recordings on 14-04-20. Not sure if it will help. There seems something a little odd with last modified times for some files, butI could be mistaken.

Ian
Title: Re: Same program recorded 8 times on T2
Post by: prl on April 15, 2020, 10:20:51 AM
Perhaps more interesting: can you see any shutdowns/restarts of enigma2 in /home/root/logs/enigma2_execution.log during the time that the recording was being made?

Especially ones where the "terminated with code" value is 129 or more, and more especially where it's 137?
Title: Re: Same program recorded 8 times on T2
Post by: Daniel Hall at IceTV on April 15, 2020, 10:28:25 AM
Hi Ian,

Looking at the list of recordings confirms my suspicions, its not overlapping recordings, but multiple separate recordings where it stops and starts.

We have seen this once before on MD's Beyonwiz, and Beyonwiz never managed to find the issue, but it looked to be related to a crash in enigma2.

The only fix we managed was that he had to reflash the firmware via USB and set the device up from scratch, since then it hasn't happened again.
Title: Re: Same program recorded 8 times on T2
Post by: prl on April 15, 2020, 10:39:02 AM
Looking at the list of recordings confirms my suspicions, its not overlapping recordings, but multiple separate recordings where it stops and starts.

That's what I suspect, too. The log file that I asked about should confirm if it's the enigma2 process dying that's the cause rather than kernel panics causing a full reboot.
Title: Re: Same program recorded 8 times on T2
Post by: IanL-S on April 15, 2020, 10:42:50 AM
Yes, there are multiple shutdowns of enigma2 terminated with code 137; I will do as Daniel suggests and reinstall the firmware via USB.

Log content below (doubt that it is really needed):
Wed Jan 29 23:31:55 AEDT 2020: enigma2 terminated with code 137
Wed Jan 29 23:31:56 AEDT 2020: executing enigma2
Sat Feb  1 15:21:45 AEDT 2020: executing enigma2
Wed Feb 19 23:25:03 AEDT 2020: enigma2 terminated with code 137
Wed Feb 19 23:25:04 AEDT 2020: executing enigma2
Tue Apr 14 23:14:40 AEST 2020: enigma2 terminated with code 137
Tue Apr 14 23:14:41 AEST 2020: executing enigma2
Tue Apr 14 23:15:54 AEST 2020: enigma2 terminated with code 137
Tue Apr 14 23:15:55 AEST 2020: executing enigma2
Tue Apr 14 23:24:30 AEST 2020: enigma2 terminated with code 137
Tue Apr 14 23:24:30 AEST 2020: executing enigma2
Tue Apr 14 23:31:59 AEST 2020: enigma2 terminated with code 137
Tue Apr 14 23:32:00 AEST 2020: executing enigma2
Tue Apr 14 23:38:56 AEST 2020: enigma2 terminated with code 137
Tue Apr 14 23:38:58 AEST 2020: executing enigma2
Tue Apr 14 23:44:59 AEST 2020: enigma2 terminated with code 137
Tue Apr 14 23:45:00 AEST 2020: executing enigma2
Tue Apr 14 23:53:09 AEST 2020: enigma2 terminated with code 137
Tue Apr 14 23:53:10 AEST 2020: executing enigma2
Tue Apr 14 23:54:34 AEST 2020: enigma2 terminated with code 137
Tue Apr 14 23:54:35 AEST 2020: executing enigma2
Wed Apr 15 00:04:29 AEST 2020: enigma2 terminated with code 137
Wed Apr 15 00:04:30 AEST 2020: executing enigma2

Ian

Title: Re: Same program recorded 8 times on T2
Post by: prl on April 15, 2020, 10:53:37 AM
The most common reason for enigma2 dying with exit code 137 (terminated by SIGKILL) is memory exhaustion. repeated restarts like that suggest that it wasn't enigma2 that was responsible for the system running out of memory (if that was the cause), since the problem kept re-occurring.

It's unusual behaviour, and hard to pin down. Do you run any plugins other than the ones pre-loaded with the firmware?

The issue almost certainly isn't due to IceTV, at least not the server side.
Title: Re: Same program recorded 8 times on T2
Post by: IanL-S on April 15, 2020, 11:46:34 AM
Peter

Definitely running the IceTV plug-in; not sure what other plug-ins I have loaded (if any). I will try doing a clean install, and monitor the situation.

Ian
Title: Re: Same program recorded 8 times on T2
Post by: prl on April 15, 2020, 12:47:27 PM
Definitely running the IceTV plug-in

Clearly, but that's one of the "pre-loaded" ones that I mentioned in my post. I meant things like plugins downloaded using PLUGIN, GREEN Download plugins, or manually installed plugins like Series2Folder & OverlayHD.

I will try doing a clean install, and monitor the situation.

It's worth a try.
Title: Re: Same program recorded 8 times on T2
Post by: IanL-S on April 16, 2020, 08:17:55 AM
Perter, understood. I have not downloaded any of those plugins as far as I can remember.

No further crashes since early AM on 15 April. Will monitor and report back (have a backup T2 just in case).

Ian
Title: Re: Same program recorded 8 times on T2
Post by: prl on April 16, 2020, 09:58:24 AM
Problems like this are hard to diagnose, because really the only way to do it is to log in to the PVR while the problem is happening and use commandline tools to try to find the memory hog.

Unless someone can work out a scenario that causes the problem reasonably reliably, the checking has to e done by the affected user.

I'm sure that IanL-S & Daniel already know, but for any other people following the topic: this is a Beyonwiz issue, not an IceTV server issue.
Title: Re: Same program recorded 8 times on T2
Post by: MD on April 16, 2020, 02:29:07 PM
My U4 did it randomly, maybe once a month than nothing for two plus months. We could see no relationship between the fault and choice of first tuner, auto, or multiple channel recordings using them all. We also never managed to make it happen which was frustrating. After the complete update, as Dan suggested, about 6 months ago, it has never reappeared.