IceTV Forum

IceTV Guide for IceTV enabled PVRs => SKIPPA => Topic started by: TimC on June 09, 2016, 09:44:03 PM

Title: No EPG
Post by: TimC on June 09, 2016, 09:44:03 PM
This afternoon I discovered that the Skippa no longer has an EPG.
The recognition of codes from the Remote is a bit flaky too.

Of course without the EPG there are no recordings

I can Ping the Skippa OK, so the network connection is OK.

I have restarted it a few times as well


Any other suggestions?
Title: Re: No EPG
Post by: Dave at IceTV on June 09, 2016, 10:18:04 PM
Hi Tim,

The good news is that it is not your SKippa playing up. It is IceTV.

We migrated to new servers this afternoon and everything seemed okay for a while but now all recorders are unable to download the guide or recording schedules.

- Windows Media Centers are showing "500 internal server" errors.
- Beyonwiz DP series PVRs are showing "500 internal server" errors.
- Beyonwiz T series PVRs are showing "Can not retrieve channel map. Read time out." errors.
- Topfield PVRs are showing "Cannot connect to server" errors.
- EyeTV software is showing "Cannot connect to server" errors.
- I haven't tested a Humax but I suspect they aren't coping too well either.
- Skippas are probably affected the worst as they stop responding to their remote control with no obvious error message making them currently unusable.
Title: Re: No EPG
Post by: TimC on June 09, 2016, 10:21:59 PM
Any forecast for a fix?
Title: Re: No EPG
Post by: Daniel Hall at IceTV on June 09, 2016, 10:27:21 PM
Any forecast for a fix?

It is being worked on... No ETA at this stage.
Title: Re: No EPG
Post by: Daniel Hall at IceTV on June 10, 2016, 01:53:51 AM
As an update:

Fixed:

- Windows Media Centers
- Beyonwiz DP series PVRs
- Topfield PVRs
- EyeTV
- Humax PVR's

Still working on:

- Beyonwiz T series PVRs
- Skippas
Title: Re: No EPG
Post by: Lindsay on June 10, 2016, 08:31:09 AM
My Widget is also presently defunct as a result of the above.
Even though the Widget is no longer supported it was working yesterday morning.
I hope it's service will be restored when others are.
Title: Re: No EPG
Post by: mouseandchicken on June 10, 2016, 09:34:14 AM
Hi,

My Humax is working fine, but my Topfield is still getting the error "Cannot connect to server"
Could this be related to this issue?
Title: Re: No EPG
Post by: Tiphanee on June 10, 2016, 09:35:59 AM
Hi mouseandchicken -

Yes - it will definitely all be related.  I'll let you know when we're back up and running.

Cheers,

Tiphanee
Title: Re: No EPG
Post by: mouseandchicken on June 10, 2016, 09:47:27 AM
Thankyou
Title: Re: No EPG
Post by: aja07 on June 10, 2016, 10:06:31 AM
Windows Media center still not working
Title: Re: No EPG
Post by: Daniel Hall at IceTV on June 10, 2016, 10:49:40 AM
All services should now be back up and running.
Title: Re: No EPG
Post by: Lindsay on June 10, 2016, 10:59:23 AM
The Widget is fully recovered as well.

Thanks.
Title: Re: No EPG
Post by: Jondalar on June 10, 2016, 11:03:00 AM
Glad I checked here, I had this issue with my Skippa last night and thought it had finally died and I was going to have to replace it.
Title: Re: No EPG
Post by: Dave at IceTV on June 10, 2016, 12:29:01 PM
All my PVRs and Media Centers automatically resumed logging in to IceTV, except for my Topfield. On the Topfield I just needed to disable then enable IceTV. 
Title: Re: No EPG
Post by: mouseandchicken on June 10, 2016, 06:31:35 PM
thanks guys..  all up and running now
(and thanks Dave..  did as you said and the Topfield is back too)

Glad I checked here too.
Title: Re: No EPG
Post by: TimC on June 11, 2016, 12:45:43 PM
Just a suggestion.
This would have been worth sending out a global email for, or at least a post on the forum of affected PVR Types.
I spent a bit of time thinking that the problem was at my end.
Title: Re: No EPG
Post by: mouseandchicken on June 22, 2016, 10:20:46 PM
Hi

Is your epg down tonight.   Both my topfield and humax are failinv to login
My network and account look ok.
Thought I would check here. 
Title: Re: No EPG
Post by: Dave at IceTV on June 23, 2016, 12:01:14 AM
For anyone else looking here for an answer (mouseandchicken found the answer in another topic)

We are currently (and still) looking at an issue affecting Topfield PVRs and Humax PVRs.

No other recording devices that I've tested are affected. But apparently some other recorders were temporarily unable to login.
Title: Re: No EPG
Post by: watrob on June 23, 2016, 12:06:23 AM
My MCE,s are not downloading either, getting errors:-

23/06/2016 12:15:34 AM   Warn   Exception System.Net.WebException - The remote server returned an error: (401) Unauthorized.

and

23/06/2016 12:16:34 AM   Error   Invalid username/password.

Thanks
Title: Re: No EPG
Post by: Dave at IceTV on June 23, 2016, 01:26:09 AM
I saw this myself. I just needed to login again and then it was able to sync with the server.

Open IceTV Interactive and click on the Login button and wait 10 seconds. Then if it doesn't start downloading on it's own click on the Sync now button.
Title: Re: No EPG
Post by: DeltaMikeCharlie on June 23, 2016, 06:25:12 AM
We are currently (and still) looking at an issue affecting Topfield PVRs and Humax PVRs.
On my Topfield, I have written a TAP that extracts EPG data from http://remote-topfield.icetv.com.au/cgi-bin/pimp/pimp_server just like the PVR does.  The TAP still gets EPG data, the PVR firmware EPG does not.

The PVR gives the message "ERROR - Cannot Connect to Server", but my wget command appears to work fine.

My TAP requests a full data set (once a day) whereas the PVR requests incremental data sets throughout the day.  Maybe this could be a factor.

I hope this helps.
Title: Re: No EPG
Post by: IanL-S on June 23, 2016, 08:34:02 AM
I must be fortunate, I have not noticed this on any of my Toppys.

Just fired up WebControl and checked my 7 Toppys (mixture of 7100+, 2400 and a 5300) that use IceTV and EPG is complete as far as the morning on 28 June, and incomplete on 29 June. So it looks like I too may be have problems.

Ian
Title: Re: No EPG
Post by: Dave at IceTV on June 23, 2016, 10:38:05 AM
We are currently (and still) looking at an issue affecting Topfield PVRs and Humax PVRs.
On my Topfield, I have written a TAP that extracts EPG data from http://remote-topfield.icetv.com.au/cgi-bin/pimp/pimp_server just like the PVR does.  The TAP still gets EPG data, the PVR firmware EPG does not.

The PVR gives the message "ERROR - Cannot Connect to Server", but my wget command appears to work fine.

My TAP requests a full data set (once a day) whereas the PVR requests incremental data sets throughout the day.  Maybe this could be a factor.

I hope this helps.

Thanks Mike. I noticed your TAP was working okay when I was looking at random accounts to see which devices were affected and just by chance clicked on your account.
Title: Re: No EPG
Post by: heggs on June 23, 2016, 10:48:51 AM
Hi, just to share, my TF-2400 is out of action also as of yesterday arvo. I performed the latest firmware upgrade in response to no avail.

I ran a packet sniff on the unit and it's successfully logging into and retrieving from remote-topfield.icetv.com.au/cgi-bin/epg/webpimpdevices.cgi?op=get_devices&format=plist

I'm happy to share my packet data if you'd like.
Title: Re: No EPG
Post by: themolk on June 23, 2016, 11:43:03 AM
I'm experiencing the same problem as watrob (have just logged a Tech Support call).

Authorisation fail. No sync now because no login option.

App shows "Synchronisation paused while Internet is unavailable". It's not unavailable.

I just can't login.
Title: Re: No EPG
Post by: Daniel Hall at IceTV on June 23, 2016, 11:59:15 AM
Hi, just to share, my TF-2400 is out of action also as of yesterday arvo. I performed the latest firmware upgrade in response to no avail.

I ran a packet sniff on the unit and it's successfully logging into and retrieving from remote-topfield.icetv.com.au/cgi-bin/epg/webpimpdevices.cgi?op=get_devices&format=plist

I'm happy to share my packet data if you'd like.

I would love to see the packet capture, will pm you.
Title: Re: No EPG
Post by: IanL-S on June 23, 2016, 12:00:28 PM
On a Toppy the absence of login usually means that the Toppy was not able to log in to IceTV when powered up and (for some reason) it assumes there is no network connection. Hence the inability to log in 'manually'.

Merely activating network connection is not sufficient, you have to reboot the Toppy. However, it the Toppy is unable to log in when it reboots due to reasons other than the absence of network connection, then you will be no further forward.

Ian
Title: Re: No EPG
Post by: mattyd on June 23, 2016, 02:37:07 PM
Nothing much to add other than to say my new Topfield 5300 stopped receiving ICE TV data today with the error cannot connect to server.

Have tried several reboots and manual log out and log back in to the ice portal....to no avail.

But i have faith in guru Dave that he will have this sorted in no time !!

Cheers guys,

Matt

PS As i don't own a skippa, i was only able to see this page from a moderator kindly redirecting me to this post. Can i suggest a global status section or traffic light option might be added to the app or at least to this forum?  Great idea? Hell yes it is ;)
Title: Re: No EPG
Post by: Dave at IceTV on June 23, 2016, 03:28:27 PM
PS As i don't own a skippa, i was only able to see this page from a moderator kindly redirecting me to this post. Can i suggest a global status section or traffic light option might be added to the app or at least to this forum?  Great idea? Hell yes it is ;)

Definitely a great idea and it is on our to do list. We discuss the need for an easy to find server status section or web page each time there is an issue, but when we aren't having an issue it is low priority.
Title: Re: No EPG
Post by: Dave at IceTV on June 23, 2016, 03:39:28 PM
I don't why this topic is in the Skippa section, but for those who may be following it for updates:

Status Update

We're still checking and working on various things but it is looking a lot better.
Title: Re: No EPG
Post by: Dave at IceTV on June 23, 2016, 06:34:26 PM
Status Update 2

Almost there now.
Title: Re: No EPG
Post by: Dave at IceTV on June 23, 2016, 10:17:29 PM
Status Update 3

All Recorders should now be working properly - 10pm Thu 23rd June.