IceTV Forum

IceTV General => IceTV EPG Content => Topic started by: JPP on May 17, 2016, 07:43:30 PM

Title: Timers not set on my Topfield 2400. Solved - 2 Toppies had identical IDs.
Post by: JPP on May 17, 2016, 07:43:30 PM
For a while now, at various times, my timers have not been sent to my Topfield 2400, even though they are marked as being sent and show (solid dots). There are no clashes and no error messages are/have been received for these missing timers.

Tonight I have 4 timers set - 2 on ABC and 2 on SBS. Only one, "Insight" has come through - Dateline, Foreign Correspondent and "The Indian Dream Hotel are all missing.

As I said, this has been an ongoing issue for some time now. Updating/rescheduling the timers does not help.

I next deleted the series and then reset them to record (all series recordings), with the result that 2 shows, are now marked as having issues (yellow triangle). There are no conflicts, so something is amiss at the server end I suspect.

I did get the email notification through about the failures, so that part seems to work OK.
Title: Re: Recordings not set on my Topfield 2400
Post by: JPP on May 17, 2016, 08:34:44 PM
After deleting all the timers again and then rescheduling them seems to have put the system in a spin. Timers are queued (hollow doughnuts) but don't get sent.
Title: Re: Recordings not set on my Topfield 2400
Post by: Dave at IceTV on May 17, 2016, 09:35:06 PM
Topfield PVRs will ignore deleted and recreated schedules if it had already downloaded them before. If it thinks it already has set them it will ignore all attempts to resend them.

There are specific steps required to delete the existing reservations in such a way that the Topfield will accept setting them again.

The hard way is a factory reset, then set it from scratch including the network and IceTV, followed by resending the recording from My Account.

The easier way is to Clear the Service List from the System Recovery menu, rescan the channels, re-enable IceTV, followed by resending the recordings from My Account.

Any other method will result in the Topfield ignoring your schedules for the next 5 days.
Title: Re: Recording Timers not set on my Topfield 2400
Post by: JPP on May 17, 2016, 10:12:01 PM
Thanks Dave for your quick response, and explanation of how the system/server works - never knew about this behaviour.

It turns out, that my second Toppy (designated Toppy No 2) was somehow reset to be my first Toppy (Toppy No 1). I thus had 2 Toppy No 1s. All timers were set to Toppy No 1.

In this battle of who should win, it turned out that the second Toppy won and it in fact recorded the missing shows.

I've now corrected the problem and will monitor the 2 Toppies for the next 5 days.

Thanks again for the quick response.
Title: Re: Recording Timers not set on my Topfield 2400
Post by: Dave at IceTV on May 18, 2016, 08:52:41 AM
It turns out, that my second Toppy (designated Toppy No 2) was somehow reset to be my first Toppy (Toppy No 1). I thus had 2 Toppy No 1s. All timers were set to Toppy No 1.

This will happen if you Reset the EPG using the Red F1 button from the IceTV menu. The toppy then defaults to the first device in the account's device list. Just another quirk of toppy ownership.

In this battle of who should win, it turned out that the second Toppy won and it in fact recorded the missing shows.

LOL, yep, it's a case of which toppy fetches the timers first after they get queued in the account.
Title: Re: Recording Timers not set on my Topfield 2400
Post by: JPP on May 18, 2016, 10:37:42 AM
This will happen if you Reset the EPG using the Red F1 button from the IceTV menu. The toppy then defaults to the first device in the account's device list. Just another quirk of toppy ownership.

Wow, something else I didn't know... :(.
I did this though AFTER I had the issues with Toppy 1, suggesting that before that, it still had the Toppy No 2 ID and I should have had all the timers come through to Toppy No 1. Which then means that the problems I had (and have had for some time) were not related to having the same ID for both Toppys.....

Time will tell I guess whether the issue is solved. Anyways, thanks for the informative and educational advice Dave.