IceTV Forum

IceTV Guide for IceTV enabled PVRs => Beyonwiz => Topic started by: simoncasey on December 02, 2015, 08:37:34 AM

Title: Blank title in timer
Post by: simoncasey on December 02, 2015, 08:37:34 AM
Does anybody with a t series currently have any icetv timers with blank titles. I'm trying to track what is happening to them but I don't have any at present as the last ones got tidied up.

This is a follow on from another thread that went off topic slightly. http://forum.icetv.com.au/iceforum/general-discussions/1/resend/4840/msg25296#msg25296
Title: Re: Blank title in timer
Post by: tonymy01 on December 02, 2015, 10:11:27 AM
Found some, they are quite a way into the future though...  all on SBS2 10th Dec.
Guide is well and truly blank from 9th Dec.  Finishes around 8th Midnight.  See attachments.
Title: Re: Blank title in timer
Post by: tonymy01 on December 02, 2015, 10:26:12 AM
And, checking my recordings, a bunch on Ten?
I am not sure if this is where timeshift is saved, I am os at the moment and my 10year old son is trying to learn to use the PVR, perhaps he kept saving the timeshift buffer and this might explain those?
edit:  actually, no, it is the shows Biggest Loser, Limitless and the F1, all on Ten Digital.
Title: Re: Blank title in timer
Post by: simoncasey on December 02, 2015, 10:29:20 AM
Thanks

Do you know what the blank timers might be for? It's obviously hard to tell without a title. I could set the same program to record and see what I get too.

From here I expect a few possible outcomes

1 they will disappear and then the real timers will appear closer to right day (probably on Friday)
2 they will stay as blank and the epg will get populated. I believe that at this stage of is possible to restart the BW and for the title to be updated
3 there will be a empty area in the epg and the titles will remain blank

I believe that if outcome 3 happens or outcome 2 happens and you don't restart the BW during the week then you will end up with a recording with a blank title

Unfortunately, outcome 1 is the most common and they just end up resolving themselves closer to the time
Title: Re: Blank title in timer
Post by: csutak40 on December 02, 2015, 10:30:59 AM
Can I ask an  OT question?  How do you make screen shots like the above.  The only way I can think of is to take an actual photo of it, but it never looks as good as these, so there must be a trick I  don't know about  :D
Title: Re: Blank title in timer
Post by: tonymy01 on December 02, 2015, 10:37:48 AM
I am overseas, so photos of the screen is difficult ;)
Luckily the T series Beyonwiz have a web interface.    Ignore the URL in my web page screen cap below here, I am doing some SSH port tunnelling as no matter what client I try, I cannot seem to get my router VPN working successfully, so using SSH with port mapping over the tunnel.   The URL in your house will be http://ip_address_of_beyonwiz   (or name like beyonwizt4 works I think, except I have 2xt4, I can set a name in the router thankfully).
 
So then it is just a matter of right click save image, very nifty!   You can edit bouquets, view EPG and other stuff too in the web interface, so very handy.   If you manage to get a decent router with good VPN suppport (not like my lousy Netgear DGND3700v2 which has something, but every client I have tried including the Netgear commercial one refuse to connect), then, with a public DNS (i used to use dyndns but they started charging, now using the router supported no-ip/ddns.net), then you can access your home network from a remote location securely.
Title: Re: Blank title in timer
Post by: tonymy01 on December 02, 2015, 10:56:12 AM
Do you know what the blank timers might be for? It's obviously hard to tell without a title.
I edited my post as you posted.  It seems to be for 3 shows all back to back on Sunday night, it didn't impact Monday night at all.   I don't put the Wiz into full standby, just warm standby (dunno if my son used it over that period either, he usually doesn't).
See following night is fine..

p.s. the scrolling is a bit annoying in the Wiz, I wanted to show all the SBS guides, but once you reach the bottom of the EPG page when moving down channel by channel, it goes up a full page at a time, for both EPG and recordings it seems.
Title: Re: Blank title in timer
Post by: simoncasey on December 02, 2015, 11:17:09 AM
Do you know what the blank timers might be for? It's obviously hard to tell without a title.
I edited my post as you posted.  It seems to be for 3 shows all back to back on Sunday night, it didn't impact Monday night at all.   I don't put the Wiz into full standby, just warm standby (dunno if my son used it over that period either, he usually doesn't).
I meant the future timers on SBS 2. If I know what they are I can see if I get the same blank timers. I'm trying to see if the blank timer thing is a system wide problem affecting everybody who records the same show (maybe in a region) or a random thing where different people get different empty titles.
Title: Re: Blank title in timer
Post by: csutak40 on December 02, 2015, 12:40:20 PM
  The URL in your house will be http://ip_address_of_beyonwiz   (or name like beyonwizt4 works I think, except I have 2xt4, I can set a name in the router thankfully).


Thanks very much!
Title: Re: Blank title in timer
Post by: prl on December 02, 2015, 04:47:37 PM
... or name like beyonwizt4 works I think, except I have 2xt4, I can set a name in the router thankfully ...
On routers that will add the T series Beyonwizes to their DNS automatically, you can just change the network name of the T series box and reboot it.

MENU>Setup>Network>Network services>Mount manager>Change hostname. Yes, I think its a bit of an odd place to put it, too :)
Title: Re: Blank title in timer
Post by: Dave at IceTV on December 02, 2015, 10:31:07 PM
... or name like beyonwizt4 works I think, except I have 2xt4, I can set a name in the router thankfully ...
On routers that will add the T series Beyonwizes to their DNS automatically, you can just change the network name of the T series box and reboot it.

MENU>Setup>Network>Network services>Mount manager>Change hostname. Yes, I think its a bit of an odd place to put it, too :)

Not only an odd place but also some odd behaviour when it comes to case sensitivity. When I first got my T3 I renamed it's hostname to BeyonwizT3 with a capitol B and a capitol T but then my router's Network Map showed it as BeyonwizT3beyonwizt3 and when I wanted to access the T3 via openwebif or it's UNC name I needed to use it's IP address instead. So I put it back to beyonwizt3.
Title: Re: Blank title in timer
Post by: prl on December 03, 2015, 12:00:03 PM
I'll try changing the case of the hostname on one of my test T3s to include capitals. Capitols (https://en.wikipedia.org/wiki/United_States_Capitol#/media/File:US_Capitol_east_side.JPG) are usually too big to fit inside a PVR ;)
Title: Re: Blank title in timer
Post by: simoncasey on December 03, 2015, 12:10:06 PM
I'll try changing the case of the hostname on one of my test T3s to include capitals. Capitols (https://en.wikipedia.org/wiki/United_States_Capitol#/media/File:US_Capitol_east_side.JPG) are usually too big to fit inside a PVR ;)
If you want to change the case to Capitols, then you will literally need to change to a bigger case :)
Title: Re: Blank title in timer
Post by: prl on December 03, 2015, 12:25:59 PM
I just had a look at the name mappings for my Beyonwizes in my router (Fritz!Box 7390), and one of my test T3s showed up as beyonwizt3beyonwizt3 without  me making any changes to it. It was definitely in the router's DNS as beyonwizt3beyonwizt3 (running dnslookup only returns a mapping for that name, not for beyonwizt3). It was accessible as beyonwizt3 yesterday, and I haven't done anything to its network name recently. The name in /etc/hostname is beyonwizt3.

Even after shutting it down, clearing its entries from the router and rebooting, it's still showing up as beyonwizt3beyonwizt3.  ::)

Some time ago I changed the name of the other test T3 to the unimaginative beyonwizt3a. That's in the router tables with the correct name.

It doesn't look as though the problem has anything to do with upper case letters (or large legislature buildings) in the name. I have no idea whether it's the Beyonwiz or the router that's the guilty party.
Title: Re: Blank title in timer
Post by: simoncasey on December 03, 2015, 12:37:43 PM
I just had a look at the name mappings for my Beyonwizes in my router (Fritz!Box 7390), and one of my test T3s showed up as beyonwizt3beyonwizt3 without  me making any changes to it. It was definitely in the router's DNS as beyonwizt3beyonwizt3 (running dnslookup only returns a mapping for that name, not for beyonwizt3). It was accessible as beyonwizt3 yesterday, and I haven't done anything to its network name recently. The name in /etc/hostname is beyonwizt3.

Even after shutting it down, clearing its entries from the router and rebooting, it's still showing up as beyonwizt3beyonwizt3.  ::)

Some time ago I changed the name of the other test T3 to the unimaginative beyonwizt3a. That's in the router tables with the correct name.

It doesn't look as though the problem has anything to do with upper case letters (or large legislature buildings) in the name. I have no idea whether it's the Beyonwiz or the router that's the guilty party.

Have you tried it on a T4? MrQuade posted earlier that he thought that they had different versions of network software that affected how the T3s name resolution appeared in network browsing - although that was using a master browser rather than dns.

Not sure what any of this has to do with blank titles appearing in IceTV timers.
Title: Re: Blank title in timer
Post by: prl on December 03, 2015, 07:36:25 PM
...
Not sure what any of this has to do with blank titles appearing in IceTV timers.
It's a digression started when someone asked about how to do screenshots. If anyone is interested in following it up, it's probably best done in a separate topic, on the Beyonwiz forum.
Title: Re: Blank title in timer
Post by: simoncasey on December 03, 2015, 08:01:52 PM
...
Not sure what any of this has to do with blank titles appearing in IceTV timers.
It's a digression started when someone asked about how to do screenshots. If anyone is interested in following it up, it's probably best done in a separate topic, on the Beyonwiz forum.

Yes, I agree. But also its a bit annoying that icetv support can comment on something that is specific to the T3 and completely unrelated to icetv and yet hasn't added any input to the actual topic which is an issue that affects icetv users directly.
Title: Re: Blank title in timer
Post by: kruzenvax on December 07, 2015, 07:49:23 PM
1. I have noticed that I'm also experiencing "blank" timers - mostly on Monday/Channel 10. They do not get resolved automatically -  e.g. today I have lost 3pm Judge Judy (the timer was pointing to this show but it didn't have a title and did not record). It is not the 1st time it i s happening.

2. Also noticed (not sure if related) - when I'm in Timer Edit/Info screen (Timers then OK on a timer entry) when I'm at 2 to fields (name and description) 2 panels appear on the left. The top one has the value for the field (e.g. text of the name or description) but the bottom one is full of "garbage" e.g. qwee1212 fjkjf83883 etc.

Would like to learn of there is a solution to 1. and if 2. is normal/related

Thanks
Title: Re: Blank title in timer
Post by: simoncasey on December 07, 2015, 08:00:50 PM
1. I have noticed that I'm also experiencing "blank" timers - mostly on Monday/Channel 10. They do not get resolved automatically -  e.g. today I have lost 3pm Judge Judy (the timer was pointing to this show but it didn't have a title and did not record). It is not the 1st time it i s happening.
Can you check that you don't have a recording with the just a date and time. Normally most people have ended up with a recording with the dodgy name, rather than no recording at all.

Also, I have posted elsewhere today, but a reboot of the T3 seems to repopulate the blank title, assuming that there is epg data.

Can you check to see if you have any current timers with blank titles.
Title: Re: Blank title in timer
Post by: kruzenvax on December 07, 2015, 08:27:25 PM
No, it does not like I have any recording - at least I don't see it in the list when I press "Media".

I have reloaded all IceTV timers since I have discovered the issue, so no "empty" timers at the moment. Next time I have an empty one I'll check if T4 reboot fixes that.

Thanks
Title: Re: Blank title in timer
Post by: simoncasey on December 07, 2015, 08:31:12 PM
No, it does not like I have any recording - at least I don't see it in the list when I press "Media".

I have reloaded all IceTV timers since I have discovered the issue, so no "empty" timers at the moment. Next time I have an empty one I'll check if T4 reboot fixes that.

Thanks

The reboot only seems to fix it if the epg data is there. So if you could, please check to see if there is actually epg data for the problem time.
Title: Re: Blank title in timer
Post by: kruzenvax on December 07, 2015, 09:08:15 PM
When I noticed an empty timer (no name or description) for Channel 10 3 pm today, I went to the EPG and the show name and description was there.

Title: Re: Blank title in timer
Post by: simoncasey on December 07, 2015, 09:11:18 PM
When I noticed an empty timer (no name or description) for Channel 10 3 pm today, I went to the EPG and the show name and description was there.
So you normally shut down your BW (ie deep standby) or do put in normal standby or leave it always on.
Title: Re: Blank title in timer
Post by: csutak40 on December 08, 2015, 01:05:25 AM

Can you check that you don't have a recording with the just a date and time. Normally most people have ended up with a recording with the dodgy name, rather than no recording at all.

Also, I have posted elsewhere today, but a reboot of the T3 seems to repopulate the blank title, assuming that there is epg data.

Can you check to see if you have any current timers with blank titles.
Well, you're not asking me, but I do have quite a few blank timers.  Mine seem to start on Thursday.  As it happens, I reloaded all the timers yesterday, it didn't fix the problem.  OTOH, I had a blank one (I know of) last week, but it seemed to record (with the correct title) anyway
I  am working with Dave about another problem, so I presumed this was my problem only, but it seems other people have blank timers too
Title: Re: Blank title in timer
Post by: simoncasey on December 08, 2015, 06:56:17 AM
Thanks Judy. A few questions:
Is your epg blank on those days or are the shows there?
Do you normally fully shutdown your BW or do you put it in standby or leave it on.
If the epg data is there for those timers, can you try restarting the BW and see if the timers get allocated a title.
Title: Re: Blank title in timer
Post by: kruzenvax on December 08, 2015, 07:46:11 AM
When I turn it off (Harmony 650) it goes to normal stand by. I have a sleep timer that puts it in deep standby (blue light only on the panel) after 30 minutes of inactivity  in normal stand by. So most of the day (when nobody is home) including 3 pm the unit spends in deep standby.

Does this answer the question?

Thanks
Title: Re: Blank title in timer
Post by: csutak40 on December 12, 2015, 09:33:35 PM

I meant the future timers on SBS 2. If I know what they are I can see if I get the same blank timers. I'm trying to see if the blank timer thing is a system wide problem affecting everybody who records the same show (maybe in a region) or a random thing where different people get different empty titles.

When  I first wrote in this thread, I didn't have this problem, but now I do.  I had a different problem and while attempting to fix that Dave got me to re-fetch all the timers.  I noticed then that I had some blank ones appear.  I did write to Dave about it then, so far he hasn't replied, but TBH I forgot about them (they were all towards the end of the week and  presumed they will sort themselves out.  I just discovered that I ended up with 8 blank (time and date and channel only) recordings for the last two days.
I just checked, I have 14 blank ones for the next week (they seem to reduce in number towards the end of the week FWIW)  They seem to be mostly for 10, but have one or two for most of the rest as well.  Attached is the screen shot with the most on it
Title: Re: Blank title in timer
Post by: csutak40 on December 12, 2015, 09:43:39 PM
Thanks Judy. A few questions:
Is your epg blank on those days or are the shows there?
Do you normally fully shutdown your BW or do you put it in standby or leave it on.
If the epg data is there for those timers, can you try restarting the BW and see if the timers get allocated a title.

OK.  I am  going backwards.  This shows my brain dead status.  I didn't remember talking about this problem here  :-[  I got to this thread now, reading the beginning and sent the post before this one.  I then continued to read the rest of the thread and disovered a.) my post, with screen shots, and your question.

I (being new to the Wiz) get confused about standby and shut down.  I think I have it in standby all the time.  However, I now turned it off at the front off switch and back  on again, checked the timers, nothing changed.
I then gave it a hard reset (switched it off at the back) and back on again.  The missing  timers are still missing.
Title: Re: Blank title in timer
Post by: kruzenvax on December 12, 2015, 09:49:02 PM
OK, some more info from the latest occurrence today. Noticed an empty timer Channel 10 next Friday  (the 18th) afternoon - 3pm Judge Judy. When to EPG and the program info is not there. E.g. all channels seem to be ok but Channel 10 had a long empty bar for everything after midday.

Waited for an hour to ensure that EPG updates cycle does not fix it and Rebooted Beyonwiz. Now all  the info for Friday after midday is there, but timer is still empty. Tried to play with IceTV plugin (refresh, enable/disable) to get it refreshed and also rebooted T4 again - no luck.

So I think what's going on is:

1. Sometimes EPG info is not populated from IceTV. Not sure it's IceTV or T4 problems though I think I've seen some empty bars when I was using Humax
2. If at that time T4 rolls over the next timer it will naturally have not title and other fields (not sure if it will record or not, last time it dd not record)
3. Once EPG is updated (at least with reboot as it has been suggested here before) timer does not get updated and there is no apparent way to refresh it.

Hope the info above can help with fixing this issue - and hoe someone is looking into it.

Thanks

P.S. I have disabled deep standby timers - these days my T4 goes normal stand by only.
 
Title: Re: Blank title in timer
Post by: simoncasey on December 12, 2015, 10:07:05 PM
My experience is that refreshing the gaps in the epg requires the plugin to be disabled and reenabled and that giving updating a blank title with the epg just requires a Gui restart. I have also checked that doing a Gui restart with a blank title seems to fix up the blank titles irrespective of whether it is an icetv timer or not.
In most cases people haven't had a problem with blank titles recording, they just get a recording with only the date and time as the file name.

I agree that the cause seems to originate from blank data coming from icetv that doesn't seem to get updated. There doesn't seem to have been any response from icetv as to whether they believe the problem is at their end or not.

I currently have 6 timers with blank titles but they are all for >7 days in the future so no epg data as yet. As soon as I get epg data for those days I'll do a Gui restart and check that fixes my blank timers.
Title: Re: Blank title in timer
Post by: csutak40 on December 12, 2015, 10:22:15 PM
I just checked the EPG for the times when I have missing titles in the Timers list.  They are all populated, so this makes no sense to me.  I took screen shots of all the ones to do with the screen shot I posted in my previous post
Title: Re: Blank title in timer
Post by: kazz on December 12, 2015, 10:48:38 PM
Do you know what the blank timers might be for? It's obviously hard to tell without a title.
I edited my post as you posted.  It seems to be for 3 shows all back to back on Sunday night, it didn't impact Monday night at all.   I don't put the Wiz into full standby, just warm standby (dunno if my son used it over that period either, he usually doesn't).
See following night is fine..

p.s. the scrolling is a bit annoying in the Wiz, I wanted to show all the SBS guides, but once you reach the bottom of the EPG page when moving down channel by channel, it goes up a full page at a time, for both EPG and recordings it seems.

I have a bunch of recordings that all look like the one you highlighted, I've had it happen quite a few times now but had about 5 today/overnight all of the current ones are channel 10/11.

Edit: I have a T3.
Title: Re: Blank title in timer
Post by: simoncasey on December 12, 2015, 11:14:05 PM
I just checked the EPG for the times when I have missing titles in the Timers list.  They are all populated, so this makes no sense to me.  I took screen shots of all the ones to do with the screen shot I posted in my previous post

Can you try doing a GUI restart of your t4 from the power menu and see if the timer titles get populated.
Title: Re: Blank title in timer
Post by: csutak40 on December 13, 2015, 12:30:08 AM


Can you try doing a GUI restart of your t4 from the power menu and see if the timer titles get populated.

I am not sure exactly how to do a GUI restart, but just a little while ago, (http://forum.icetv.com.au/iceforum/beyonwiz/17/blank-title-in-timer/4842/msg25557#msg25557 (http://forum.icetv.com.au/iceforum/beyonwiz/17/blank-title-in-timer/4842/msg25557#msg25557)) I did a complete reboot, by switching off the T4 at the back. it didn't populate the missing titles
Title: Re: Blank title in timer
Post by: simoncasey on December 13, 2015, 12:55:49 AM
Menu>Power>restart gui will do a restart. It's possible that the tidy up of the timer is done when the t3 shuts down rather than during the start up.
Title: Re: Blank title in timer
Post by: prl on December 13, 2015, 03:21:00 PM
On GUI restart, the following happens to IceTV and existing timers:
That process should be the same whether the just GUI is restarted, or whether the GUI is restarted because of a reboot/restart.

If the PVR has been off for a while, then when it restarts, the name lookups in the timer list load won't have the most recent copy of the EPG, so doing another GUI restart may fill in some timers that the reboot didn't fill in.

If the PVR doesn't shut down (or have a GUI restart), the only parts of the process that can fill in missing timer names is the fetch of IceTV timer updates, and then only if there's another change in the timer (e.g. timeslot change) to trigger the IceTV update.

Disabling and then re-enabling IceTV may also help fill in timer names without having to restart the GUI, because that should resend all IceTV timers.

This problem would seem most likely to happen on timers that are set at times later than the end of the EPG data for the channel. Then if the timer is missing its name in the IceTV timer data, there's no way it can find its name from the EPG, because that data hasn't yet been sent. I think that at the moment only SBS timers are sent in advance of the EPG data, though in the past, I'm fairly sure that ABC ones were, too. I think that IceTV v1 used to have agreements with ABC and SBS to use their EPGs as-is. I don't know whether that's the case with the current IceTV.

Regular restarts seem to protect against this problem. We shut down our IceTV-enabled T4 every night, and we simply don't see this problem at all. Obviously there's a bug to be fixed here, but perhaps if you shut down your devices regularly, the problem will be worked around.

I hope the description makes it clear why I think that this is basically an IceTV server problem, though I wouldn't discount contributory misbehaviour from the T series Beyonwizes.
Title: Re: Blank title in timer
Post by: simoncasey on December 13, 2015, 03:35:07 PM
Thanks prl. That certainly covers the experience I have seen but I think there is a further complication.

I some cases there are blanks in the epg and that can contribute to the blank titles, particularly on non abc/sbs channels.

I've also noticed that the blank Epg won't get updated automatically from a reboot or a icetv fetch. The only way I have found to update the blanks in the epg is to disable icetv and reenable it, which basically clears the epg and fetches the whole thing again. This is why I suggest doing this step as the gui restart won't fix the blank titles if the epg is blank. I think this blank epg is also why people get blank titles on other channels and also why the blank timer ends up as a blank recording as doing a restart won't fix it. 

Also, in terms of timers greater than 7 days that is sbs and abc. I currently have 5 abc timers with blank titles for next Sunday.
Title: Re: Blank title in timer
Post by: prl on December 13, 2015, 03:46:27 PM
...
I've also noticed that the blank Epg won't get updated automatically from a reboot or a icetv fetch. The only way I have found to update the blanks in the epg is to disable icetv and reenable it, which basically clears the epg and fetches the whole thing again. This is why I suggest doing this step as the gui restart won't fix the blank titles if the epg is blank. I think this blank epg is also why people get blank titles on other channels and also why the blank timer ends up as a blank recording as doing a restart won't fix it.

That sounds like there may also be problems in the EPG synchronisation between IceTV and the T series. I've never noticed blanks in the EPG, but then we hardly ever use it.

Also, in terms of timers greater than 7 days that is sbs and abc. I currently have 5 abc timers with blank titles for next Sunday.

The last time I looked I only had SBS timers in advance of the EPG data, but I haven't checked in a while. That's why I hedged a bit. :)
Title: Re: Blank title in timer
Post by: simoncasey on December 13, 2015, 03:52:08 PM
The blank epg data looks like it is from icetv. In most cases I have seen the same gap in the website/app, and it is often only in a specific region. It's not easy to spot unless you are looking for it.

Generally icetv are pretty quick at fixing but the issue seems to be that once there is a gap, the updated data doesn't appear on the T3 automatically, but does if you clear the epg by doing a disable of the plugin. 

You might notice it on now and next data (depending if you also have eit set for now and next) when you change channels and the now/next changers after a second or show the same show or is blank.
Title: Re: Blank title in timer
Post by: xanthi on December 13, 2015, 04:14:32 PM
From BLANK times to THIS ... Four waiting times and instead of getting the program name I get the date ... Fantastic! Not
Title: Re: Blank title in timer
Post by: simoncasey on December 13, 2015, 04:35:53 PM
From BLANK times to THIS ... Four waiting times and instead of getting the program name I get the date ... Fantastic! Not

By waiting timers, I assume you mean that the timers had blank titles.

A few questions:
Do you know if the epg had data when those timers had blank titles
Are they for shows that you regularly record or are they shows that you only recently added a series recording for.
Title: Re: Blank title in timer
Post by: xanthi on December 13, 2015, 06:05:40 PM

Quote
By waiting timers, I assume you mean that the timers had blank titles.
Indeed. All it says is "Waiting"

Quote
A few questions:
Do you know if the epg had data when those timers had blank titles
No, I assumed that it would be filled automatically when the program recorded.

Quote
Are they for shows that you regularly record or are they shows that you only recently added a series recording for.
The four timers shown were for "The Amazing Race", "Bargain Hunt" (2x) and "Escape to the Country". The shows are set as "First Run and Repeats"

Cheers, xanthi
Title: Re: Blank title in timer
Post by: simoncasey on December 13, 2015, 07:17:41 PM
Do you have any other current timers with blank titles?
Title: Re: Blank title in timer
Post by: csutak40 on December 14, 2015, 12:29:49 AM
Menu>Power>restart gui will do a restart. It's possible that the tidy up of the timer is done when the t3 shuts down rather than during the start up.

OK did that.  Made no difference.  Didn't think it would, as I have switched it off at the back a little while back and that didn't help either.  After doing that, just for the fun of it, I also disabled the IceTV plug-in, then re-enabled it and forced a new fetch.  Still the same blank timers (and they are still not blank in thee EPG
Title: Re: Blank title in timer
Post by: tonymy01 on December 14, 2015, 07:22:52 AM
It's possible that the tidy up of the timer is done when the t3 shuts down rather than during the start up.
Made no difference.  Didn't think it would, as I have switched it off at the back a little while back and that didn't help either. 
Switching it off at the back isn't a shut-down, it is an abrubt stop!  But perhaps Simon's suggestion of it tidying up on shut-down isn't the right answer anyway given your (well, our) experience is to the contrary.   
Title: Re: Blank title in timer
Post by: simoncasey on December 14, 2015, 07:40:23 AM
Menu>Power>restart gui will do a restart. It's possible that the tidy up of the timer is done when the t3 shuts down rather than during the start up.
OK did that.  Made no difference.  Didn't think it would, as I have switched it off at the back a little while back and that didn't help either.  After doing that, just for the fun of it, I also disabled the IceTV plug-in, then re-enabled it and forced a new fetch.  Still the same blank timers (and they are still not blank in thee EPG
Switching it off at the back isn't a shut-down, it is an abrubt stop!  But perhaps Simon's suggestion of it tidying up on shut-down isn't the right answer anyway given your (well, our) experience is to the contrary.

Prl posted that the gui restart is the step that fixes up blank timers from the epg so doing it twice should fix it.

This means there seems to be another issue:
Is the title blank on the icetv server and therefore after the BW fills in the title, the icetv server blanks it again
Is the title not actually blank but has some invisible characters in it (maybe a space)
Is there some other error with the timer that prevents a gui restart from fixing it
Is there a problem with the epg that prevents the GUI restart from fixing it

Whatever the cause, it is hard to reproduce at will.

I will try setting up the same timers as Judy as I'm also in Melbourne and see if there is anything odd about them.

Judy, the blanks you have on 10 today. Did you set them up as series recordings, individual recordings from icetv, individual recordings from the epg or using keyword recordings?
Title: Re: Blank title in timer
Post by: csutak40 on December 14, 2015, 01:09:43 PM


I will try setting up the same timers as Judy as I'm also in Melbourne and see if there is anything odd about them.

Judy, the blanks you have on 10 today. Did you set them up as series recordings, individual recordings from icetv, individual recordings from the epg or using keyword recordings?

OK..  Attached is what it looks like ATM.  These are all series recordings, all from IceTV.  Just looked on the IceTV website at "MyWeek" they are definitely not blanks there.   Double checked on the EPG listings, not blank there either
Thanks very much for the help
Title: Re: Blank title in timer
Post by: csutak40 on December 14, 2015, 01:21:06 PM
P.S.  I looked at the rest of the week.  No  blanks for Tuesday at all.  Wednesday some more for 10.  However, for Thursday and Sunday there are other channels  (No blanks for Friday or Saturday)
Title: Re: Blank title in timer
Post by: simoncasey on December 14, 2015, 01:46:52 PM
I set up dr phil etc and don't have the blanks for today.

But I also found some big gaps in the epg. One that affects you is channel 9 on Sunday which is currently blank and corresponds to the blank title you have for the that time.

I also found a large blank epg for Sbs food from 1 pm in Wednesday.

Title: Re: Blank title in timer
Post by: csutak40 on December 14, 2015, 04:10:27 PM
I set up dr phil etc and don't have the blanks for today.

But I also found some big gaps in the epg. One that affects you is channel 9 on Sunday which is currently blank and corresponds to the blank title you have for the that time.

I also found a large blank epg for Sbs food from 1 pm in Wednesday.

Yeah, those are blank on mine too.  I didn't check them that far ahead, sorry