IceTV Forum

IceTV Guide for IceTV enabled PVRs => Windows Vista Media Center => Topic started by: splintex on July 04, 2010, 09:37:39 AM

Title: CPU And Memory Usage
Post by: splintex on July 04, 2010, 09:37:39 AM
 ??? ??? ??? ??? ??? ??? ??? ??? ??? ??? ??? ??? ??? ??? ??? ??? ??? ??? ??? ??? ???

I constantly have this issue,  everytime the PC comes back out of Hibernate, or I reboot it, hell, it just seems like all the time, but I only notice it on reloads or reboots due to the amount of time it takes to do it.

IceTv Interactive.exe uses a metiric ***kTon (that is an Si if you are interested ^_^) of ram and sits there taking 25% of my CPU.  I have cleared out the cached tasks as suggested in another thread but to no avail.

The first attached file shows current system uptime since reboot, and a shot of task manager showing CPU and Ram usage. The Ram stays pretty constant, I'm not sure if this is how much it is meant to use? but seriously, 100+Meg for loading an XML file into windows? C'mon.

It will drop to 0% for about 30secs or so every so ofthen, say about a minute or 2, then jump back up to 25+% usage on the CPU.

Just prior to the reboot I uninstalled and re-installed the icetv program, but to no avail.  The same issue is occuring, also I get frequent appCrashes when iceTV tries to load on startup.

I check for a log file or cashed tasks and there is no ICETV folder in my C:\Users\<my-user-id>\AppData\Roaming\  dir.

Also attached is a system info dump showing current hotfixes and pc details and a zip of windows error reporting, detailing the system crashes

Please let me know if you have any suggestions on how to fix this. I have tried running it as an administrative user, I have not tried any compatibility modes as it is supposed to be fine in windows 7 64Bit, appart from that the only antivir/antispy I use is Microsoft security essentials.

HELP... and if you can't can you give me instructions on how to schedule a webget to manually load the data like during the beta... that never went wrong.
Title: Re: CPU And Memory Usage
Post by: splintex on July 05, 2010, 06:03:53 PM
I might as well respond to my own own thread  ;D

Techsupport have been really quick and helpful on this.

I didn't realise the data location is different on windows 7 to vista, and is in the program data directory.

Deleteing the entire IceTV directory under there fixed my issues, but props to the team at IceTV they are still actively pursuing this issue.

Excellent service and a good outcome all round.

Title: Re: CPU And Memory Usage
Post by: tonymy01 on July 05, 2010, 07:46:43 PM
But it works fine on my windows7 64bit... go figure?   Mind you I upgraded from vista-64bit as part of my pc manufacturer provided freebie, and I never hybernate my pc (or have it in standby).