Author Topic: Forum search is broken  (Read 6003 times)

Offline Daniel Hall at IceTV

  • Administrator
  • Guru
  • *****
  • Posts: 1341
    • View Profile
    • IceTV
Re: Forum search is broken
« Reply #15 on: May 18, 2017, 03:34:32 PM »
Five months on, and forum search still doesn't work.

The ability to preview posts (which also broke some time ago) is still missing from the Post windows.

Any idea when these might be fixed?

Such snarks, I'm told, can be found as follows:
Quote
"You may seek it with thimbles—and seek it with care;
   You may hunt it with forks and hope;
You may threaten its life with a railway-share;
   You may charm it with smiles and soap—'"

Holy crap, forum search is fixed... was an incompatibility with php7 it looks like, they used a 'continue' where it should have been a 'return', that's it... wow.
Regards,

Daniel.
CTO.

Offline prl

  • IceTV Beta
  • Guru
  • *
  • Posts: 3652
    • View Profile
Re: Forum search is broken
« Reply #16 on: May 18, 2017, 06:09:14 PM »
Are you sure it's fixed? I just did a search on "forum search is fixed", and it's improved a bit, because I got properly formatted forum page instead of The Bellman's "perfect and absolute blank," but it didn't actually have any search results in it.

Even searches for "ice" and "icetv", which I'd expect would return a lot of results, return no results.
« Last Edit: May 18, 2017, 06:10:52 PM by prl »
Peter
Beyonwiz T4 in-use
Beyonwiz T2, T3, T4, U4 & V2 for testing

Offline Daniel Hall at IceTV

  • Administrator
  • Guru
  • *****
  • Posts: 1341
    • View Profile
    • IceTV
Re: Forum search is broken
« Reply #17 on: May 19, 2017, 04:27:35 PM »
Are you sure it's fixed? I just did a search on "forum search is fixed", and it's improved a bit, because I got properly formatted forum page instead of The Bellman's "perfect and absolute blank," but it didn't actually have any search results in it.

Even searches for "ice" and "icetv", which I'd expect would return a lot of results, return no results.

Hmm, now that is very weird.

I definitely got results back when I was testing, so I just tried again and for "ice" I get 26 pages of results and for "icetv" I get 14 pages worth.
Regards,

Daniel.
CTO.

Offline prl

  • IceTV Beta
  • Guru
  • *
  • Posts: 3652
    • View Profile
Re: Forum search is broken
« Reply #18 on: May 19, 2017, 05:55:43 PM »
I just re-tried searching for "icetv", and I got no results. Nicely formatted, though :D

Just doesn't like me.  :'(
Peter
Beyonwiz T4 in-use
Beyonwiz T2, T3, T4, U4 & V2 for testing

Offline csutak40

  • Guru
  • *****
  • Posts: 1214
    • View Profile
Re: Forum search is broken
« Reply #19 on: May 21, 2017, 12:38:54 AM »
I just re-tried searching for "icetv", and I got no results. Nicely formatted, though :D

Just doesn't like me.  :'(
Apparently not.    ;D  Works for me
Cheers,
Judy
Last Update Dec 9 2020; Beyonwiz V2, T2,

Offline blip

  • Senior Member
  • ****
  • Posts: 101
    • View Profile
Re: Forum search is broken
« Reply #20 on: May 21, 2017, 05:22:09 AM »
Doesn't seem to work if you use the search box at the top right of the screen when viewing a topic but works from other screens.

Offline prl

  • IceTV Beta
  • Guru
  • *
  • Posts: 3652
    • View Profile
Re: Forum search is broken
« Reply #21 on: May 21, 2017, 09:28:17 AM »
Doesn't seem to work if you use the search box at the top right of the screen when viewing a topic but works from other screens.

Yes, now that I've checked in more detail, that's what's happening for me, too. Broken in a new and inventive manner now ;)
Peter
Beyonwiz T4 in-use
Beyonwiz T2, T3, T4, U4 & V2 for testing

An Error Has Occurred!

Call to undefined function seo_social_bookmarks()