No Timers Since Daylight Saving

Started by Paul55, October 08, 2014, 11:52:15 AM

Previous topic - Next topic


Toppy 2400 - QLD, Brisbane.
I hadn't received any timers since a successful refresh on Saturday, so tried all the usual attempts at logging in etc.
Tried deleting all timers and then resend all recordings - nothing.
I then did a factory reset/rescen as  a last resort - even though I didn't think this was the problem.
Did a resend all recordings to my Toppy and still nothing in my timers.
During this period I received an email from IceTV about failed timers. This was included in every failed timer:

Message from recorder:    TASK_MSG_INVALID_SERVICE

I have my region set as Brisbane (always have done) so daylight saving SHOULDN'T be a problem. But it's very coincidental that I haven't had any success since Saturday.
Any ideas?


Hmmm. I have a 2400 that I could never get to download timers from IceTV. I am not alone in that.

But in your case it just stopped. As the download is initiated by the Toppy, there may be something at your end that is contributing to the problem.

It could be that the request to IceTV is timing out for some reason - have you recently changed the settings on your router? I would try powering off you modem or modem/router, you router, and any switches between the Toppy and the router. The turn the back on starting with the Modem.

Are you using a static IP address on the Toppy and/or a reserved IP address on the router? If not, changing to staic/reserved may help (particularly if you connect via a wireless dongle).

If that does not work, You could always try an abundant caution firmware reinstallation (see

IceTV: 2xTRF-2400 + 2xTF7100HDPVRtPlus + SKIPPA [RIP] + T2 + U4 + V2
No IceTV: a few Toppys
Synology NAS
Check out the oztoppy wiki and oztoppy Forum for Toppy help


You could also try re-entering your username and password in the IceTV settings menu on the Toppy.
Topfield 5000, 2400, Skippa


Thanks guys.

User name/password was the first thing I tried - always get Login Successful response.

I've had no problem getting the the IceTV EPG data refreshed - using JustEPG (XML) and the native EPG. It's only timers that are the problem.

I can also log into the Toppy with TMSRemote and via the web interface.

I've experienced this before but always been able to resolve it by either resending or just waiting for it to 'fix' itself. I have a sneaking suspicion that there is glitch at the IceTV end - would be grateful if someone there could look at my Toppy's comms. (User Paul55).

I'll just do manual timers for a couple of days to see if it comes good.

Also, I'm having no issues with by Beyonwiz PVRs on the same account.

Dave at IceTV

Hi Paul,

Your Topfield is fetching and reporting back as it should. So it appears to be ignoring the new schedules (as if it thinks it already has set them). Check the selected 'device' on each of your PVRs. i.e. Make sure that the Topfield is using it's own device name and the Beyonwizes are using theirs.

if that was okay, then the following steps should get it working again:

Customer Service


Thanks Dave.
I checked that 'device' is correct on all PVRs.
I'm almost certain that I did all the things in the referenced guide with no success. However, I'll follow the points in order tomorrow and let everyone know the result.
Is it all right to save save and restore settings (which have been fine for years)?


Wondering if my DST experience this year has some relation to the problem.
In the past, On my Beyonwiz, I have been able to resend all timers at DST a time, by stopping Ice on my Bw, going to,initialise, clear all timers, do a resend all from the website, and then restart Ice on the BW.
This time this didn't work.
Tried a number of times, checked that my userid was correct, and that the correct device was selected in the configure.

I had to go to factory setting reset, and reconfigure to retrieve them successfully.
BeyonWiz, T3


OK, here's what happened.
I followed the guide and all went well - reservations downloaded within a few minutes.
Restored my settings (for favourite lists etc) - all reservations gone!!
Repeated full process - success!
It seems my settings had somehow become corrupted - which I haven't changed for months (maybe years). Strange that it happened at the DST changeover - coincidence?.
I don't get these glitches with my Beyonwiz machines, but my wife loves the Toppy so I have no choice but to persevere.
Anyway, happy that it's all working now.


The implementation of IceTV on Toppys is in need of a complete reworking. I have sent a list of issues with the implementation to both Topfield Australia and Topfield in Korea. Hopefully they will get around to fixing it. If, as mentioned elsewhere on this forum, Topfield intend adding IceTV support to one of the 6000 series Toppys, then that may be an opportunity to rework IceTV for the TRF-2400, TRF-2460 and 7100HDPVRt Plus.

IceTV: 2xTRF-2400 + 2xTF7100HDPVRtPlus + SKIPPA [RIP] + T2 + U4 + V2
No IceTV: a few Toppys
Synology NAS
Check out the oztoppy wiki and oztoppy Forum for Toppy help