Author Topic: "You've never fetched the EPG"  (Read 5052 times)

Offline rickym

  • Junior Member
  • **
  • Posts: 25
    • View Profile
"You've never fetched the EPG"
« on: June 08, 2013, 10:43:26 AM »
Hi,

My Topfield 2460 is no longer downloading EPG data -- it was doing so previously.  Under IceTV > My Account > TV Guide I get the message "You've never fetched the EPG".  I have checked "My Shows" and "My Week" and everything seems OK there.  Also, I've been into Menu > Settings > IceTV and set it to "Reset EPG Data", but to no avail.  What has happened, please and how do I fix it?  Thanks.

Cheers,

Rick

Edit:  Also I note that if I go into Menu > Entertainment > Weather, I get the error message "Cannot connect to the server".
« Last Edit: June 08, 2013, 10:50:56 AM by rickym »

Offline Dave at IceTV

  • Guru
  • *****
  • Posts: 1258
    • View Profile
    • IceTV Knowledgebase Articles
Re: "You've never fetched the EPG"
« Reply #1 on: June 08, 2013, 12:27:32 PM »
Hi Ricky,

Your Topfield is unable to connect to the Internet.

Since you are getting server errors instead of a clear network connection error you will probably find that the Topfield has "Connection Type" set to Manual, so it thinks it is connected to your network, but it cannot access the Internet beyond your router. To ensure that the connection to the router is actually working, try setting "Connection Type" set to DHCP, and if needed reboot the router (wait for the router to fully finish turning on before turning the Topfield on).

If you don't have the latest firmware you may still get the "Cannot connect to the server" error when trying to access the weather even when the Topfield has Internet access. To test Internet access, try Shoutcast instead.

The "You've never fetched the EPG" normally means that your recorder has not fetched the EPG in the last week. Looking at what I suspect is your account I can see that the Topfield has not connected to IceTV since the 23rd May (2 weeks ago). 

cheers

Dave
Customer Service

Offline rickym

  • Junior Member
  • **
  • Posts: 25
    • View Profile
Re: "You've never fetched the EPG"
« Reply #2 on: June 08, 2013, 01:04:36 PM »
G’day Dave,

Thanks for your prompt reply.  It is most appreciated.  To answer your comments/questions:

Since you are getting server errors instead of a clear network connection error you will probably find that the Topfield has "Connection Type" set to Manual, so it thinks it is connected to your network, but it cannot access the Internet beyond your router. To ensure that the connection to the router is actually working, try setting "Connection Type" set to DHCP, and if needed reboot the router (wait for the router to fully finish turning on before turning the Topfield on).

It’s not set to Manual – it’s set to Static.  A technician suggested that I change to that a couple of weeks ago to stop the IP address changing regularly (he talked me through it).  Occasionally, I copy stuff to a computer in another room.  It’s hard-wired.   I can swap to DHCP, but assume I will have to re-enter all the addresses listed on the page and will have the problem of changing IP addresses.  Is there any way around that?

If you don't have the latest firmware you may still get the "Cannot connect to the server" error when trying to access the weather even when the Topfield has Internet access. To test Internet access, try Shoutcast instead.

I only purchased the Topfield recently, having ditched a 2TB BeyonWiz – it was causing major problems and now was out of warranty.  Not a happy bunnykins.   I hope I have not jumped out of the frying pan and into the fire!  Anyway, I assume that means I have the latest firmware.  But what is “Shoutcast”?

The "You've never fetched the EPG" normally means that your recorder has not fetched the EPG in the last week. Looking at what I suspect is your account I can see that the Topfield has not connected to IceTV since the 23rd May (2 weeks ago).

Yes, that date sounds right.

Cheers,

Rick

Offline Dave at IceTV

  • Guru
  • *****
  • Posts: 1258
    • View Profile
    • IceTV Knowledgebase Articles
Re: "You've never fetched the EPG"
« Reply #3 on: June 08, 2013, 02:17:43 PM »
Hi Rick,

Setting a static address is helpful for accessing the Topfield from a computer, but if the IP address is not carefully chosen it can cause the Topfield to later lose it's network connection. e.g. If the chosen IP address is later assigned to another device by the router (DHCP server). Another potential problem is if the DNS server address assigned from your ISP changes, or the server is offline, then the Topfield will still have local network access but no Internet access.

A much safer option is to set the Topfield to DHCP, then set your router to reserve an address for the Topfield. This way the DNS address is dynamically controlled by the router and there is less chance of an IP address conflict and the address on the Topfield never changes.

Shoutcast is an Internet Radio portal on the Topfield - in the Entertainment menu.
cheers

Dave
Customer Service

Offline rickym

  • Junior Member
  • **
  • Posts: 25
    • View Profile
Re: "You've never fetched the EPG"
« Reply #4 on: June 08, 2013, 05:54:12 PM »
Hi Dave,

Thanks for that.  Your input is most appreciated. 

However, another problem has arisen:

Setting a static address is helpful for accessing the Topfield from a computer, but . . . . then the Topfield will still have local network access but no Internet access.
OK.  I’ll change it to DHCP when I can get an internet connection.   I dunno what I have done (I thought nothing), but now IceTV under Settings is greyed out as are about half the items under entertainment.  That would indicate no internet connection.  However:

•   Apple TV still works
•   The internet connection on my computers still work
•   I have switched off everything at the power point, left it all off for ten minutes, and restarted it all.  I didn’t switch on the TV or Topfield, though, until I knew the router, etc  had rebooted. 

. . . .  then set your router to reserve an address for the Topfield. . . . 

That’s OK, but how do I do that?

Shoutcast is an Internet Radio portal on the Topfield - in the Entertainment menu.

Found, but greyed out along with half the items on this page.

Cheers,

Rick

Offline Dave at IceTV

  • Guru
  • *****
  • Posts: 1258
    • View Profile
    • IceTV Knowledgebase Articles
Re: "You've never fetched the EPG"
« Reply #5 on: June 08, 2013, 10:50:42 PM »
OK.  I’ll change it to DHCP when I can get an internet connection.

Later won't solve your current problem. If you change it to DHCP now you will probably find that the Topfield's Internet connection is restored.

I dunno what I have done (I thought nothing), but now IceTV under Settings is greyed out as are about half the items under entertainment.  That would indicate no internet connection.  However:

•   Apple TV still works
•   The internet connection on my computers still work
•   I have switched off everything at the power point, left it all off for ten minutes, and restarted it all.  I didn’t switch on the TV or Topfield, though, until I knew the router, etc  had rebooted.

This just confirms that the Topfield is not connected to your network. The Statically set addresses are just making it seem like it is connected, when it is not.

. . . .  then set your router to reserve an address for the Topfield. . . . 
That’s OK, but how do I do that?

You would need to log in to your router's admin settings and tick a box to reserve the Topfield's IP address - after you have set the Topfield back to DHCP. Your router's manual will show you how exactly to reserve an IP address, if your router has this feature (try Google).

Shoutcast is an Internet Radio portal on the Topfield - in the Entertainment menu.
Found, but greyed out along with half the items on this page.

Those menu items are greyed out whenever the Topfield knows it does not have a network connection. It is telling you that your IP settings are wrong or the Ethernet cable or the wireless dongle are unplugged.
cheers

Dave
Customer Service

Offline rickym

  • Junior Member
  • **
  • Posts: 25
    • View Profile
Re: "You've never fetched the EPG"
« Reply #6 on: June 09, 2013, 07:42:39 PM »
Thanks Dave.  Most appreciated. 

OK.  I’ll change it to DHCP when I can get an internet connection.

Later won't solve your current problem. If you change it to DHCP now you will probably find that the Topfield's Internet connection is restored.

OK, but IceTV is greyed out.  So how do I change it to DHCP?

It would seem that the internet connection is OK, too.  I can access the internet using other applications as per normal.  But I can't through the Topfield PVR. 

Cheers,

Rick

Offline prl

  • IceTV Beta
  • Guru
  • *
  • Posts: 3669
    • View Profile
Re: "You've never fetched the EPG"
« Reply #7 on: June 10, 2013, 11:35:16 AM »
T...
OK, but IceTV is greyed out.  So how do I change it to DHCP?
...
You change the Internet setup on the Topfield to use DHCP. DHCP is a protocol for managing IP addresses on your local network. The IceTV servers don't even know whether you're using DHCP for your IP address configuration or not. The important thing is that you're using IP addresses in the correct way on your local net (e.g. not having two devices with the same IP address, having the IP addresses' network address correct for your local network and so on). Once you have that, and your router connects properly to the wider internet (which it appears to do), the Topfield should be able to connect to the IceTV servers.

The IceTV entry on your Topfield may be greyed out because the Topfield can't make a working IP connection, but I'm not sure, I don't have a Topfield.
Peter
Beyonwiz T4 in-use
Beyonwiz T2, T3, T4, U4 & V2 for testing

Offline rickym

  • Junior Member
  • **
  • Posts: 25
    • View Profile
Re: "You've never fetched the EPG"
« Reply #8 on: June 11, 2013, 01:05:07 PM »
Hi Dave and Peter,

Thanks very much for your input to this issue.  All is now fixed after going back to my consultant and asking him to read all the above posts. Your input was most appreciated  ;D

. . . . OK, but IceTV is greyed out.  So how do I change it to DHCP?

. . . . The important thing is that you're using IP addresses in the correct way on your local net (e.g. not having two devices with the same IP address, having the IP addresses' network address correct for your local network and so on). Once you have that, and your router connects properly to the wider internet (which it appears to do), the Topfield should be able to connect to the IceTV servers.

The IceTV entry on your Topfield may be greyed out because the Topfield can't make a working IP connection, but I'm not sure, I don't have a Topfield.

The answer to the "greyed out" question was to go through Menu > Installation > Network Setting, etc.  Now to sort out the router as you suggested above.  All is done.   Now to see if programs record correctly tonight.

Cheers,

Rick


Offline prl

  • IceTV Beta
  • Guru
  • *
  • Posts: 3669
    • View Profile
Re: "You've never fetched the EPG"
« Reply #9 on: June 11, 2013, 04:21:04 PM »
No problem. Good luck!
Peter
Beyonwiz T4 in-use
Beyonwiz T2, T3, T4, U4 & V2 for testing

Offline IanL-S

  • IceTV Beta
  • Guru
  • *
  • Posts: 1177
    • View Profile
Re: "You've never fetched the EPG"
« Reply #10 on: June 25, 2013, 05:30:48 PM »
If you are using a static IP on the Toppy, you should reserve the same IP address on the Router. This is easy with D-Link routers; with Netgear and Asus routers I've used it is a little more difficult - you have to manually add both the IP address and the MAC address - the DLink copies both for you.

Ian
IceTV: 2xTRF-2400 + 2xTF7100HDPVRtPlus + SKIPPA [RIP] + T2 + U4 + V2
No IceTV: a few Toppys
Synology NAS
Check out the oztoppy wiki and oztoppy Forum for Toppy help

An Error Has Occurred!

Call to undefined function seo_social_bookmarks()