IceTV Interactive 3.0.0.29 Released

Started by lukem, February 20, 2012, 04:18:00 PM

Previous topic - Next topic

lukem

Release Notes for IceTV Interactive version 3.0.0.29
--------------------------------------------------------
* Fixed a regression where guide data loading caused an exception

Release Notes for IceTV Interactive version 3.0.0.28
--------------------------------------------------------
* Channel Logos for most channels
* Automatic channel mapping
* Fixed an issue where the Auto-Sync option was not being saved

Thanks again to our Beta testing group for their assistance during development of this release.

bodogbodog

#1
Congratulations on the release
Will download it tonight - here's hoping for a smooth transition from the beta

Edit - went well on the unit I've used with the beta

My other Win7 MCE went 90%  - one channel - ABC3 didn't pick up a logo - everything else did - guess I'll need to do a rescan of the channels when I have some spare time
Beyonwiz V2: 4 HDTV Tuners, 16gb SD + unRaid 10TB NAS + IceTV Skippa (for old times sake - make me an offer and it's yours!)

Eaglehawk

#2
I'm getting an Exception error when I try to sync the EPG. But it's on my test system, not my main rig.

20/02/2012 8:27:12 PM   Warn   Exception System.NullReferenceException - Object reference not set to an instance of an object.

lukem

Quote from: Eaglehawk on February 20, 2012, 08:24:16 PM
I'm getting an Exception error when I try to sync the EPG. But it's on my test system, not my main rig.

20/02/2012 8:27:12 PM   Warn   Exception System.NullReferenceException - Object reference not set to an instance of an object.

Hmm.. is this issue stopping it from functioning? Also, could you please send me your logfile located in C:\ProgramData\IceTV\Interactive\3.0\ice.log and  C:\ProgramData\IceTV\Interactive\3.0\ice.log.1 ? The logfile will contain the details of the exception.

Cheers,
Luke

parki

Hi,

I'm having the same problem. Ice.log shows this:

21/02/2012 10:24:39.262: INFO Loading EPG data..
21/02/2012 10:24:39.266: WARNING Exception System.NullReferenceException - Object reference not set to an instance of an object.
21/02/2012 10:24:39.335: DEBUG    at IceTV.Interactive.MediaCenter_Win7.ClearServiceLogos()
   at IceTV.Interactive.MediaCenter_Win7.ImportGuideData(String mxfFile)
   at IceTV.Interactive.MediaCenter_Win7.LoadEpg()
   at IceTV.Interactive.Client.LoadEpg()

There's no ice.log.1.

lukem


grampus

Just FYI,
Had run .28 over the previous released version (.26?).
.26 had given me some problems.  Not noted, but recall that there were no channel logos., and unable to get a timer scheduled.  I think also I had a problem reported in logging of something like,  inablity to find, map channels.
After .28 overlay, channel logos appeared. All channel mapping OK (default).  Logs showed no exceptions or errors.
Overlayed with .29 beta, no error in logs.
Channell logos appeared, timer sent from Website ok.

Windows 7 MCE version 6.1.7601.1754
Win7 SP1
BeyonWiz, T3

parki

Quote from: Luke at IceTV on February 21, 2012, 11:07:18 AM
Thanks Parki,

Does this version fix your problem?

IceTV Interactive Beta 3.0.0.29

Yes, EPG now downloads, with no error messages. Thanks for the quick response!

Mozi

V29 seems to work perfectly. Thanks Luke and the team.

Dave

Antec NSK2480B Case & PSU, Asus M4A785TD-M-EVO motherboard, AMD Phenom II 965 3.40Ghz quad core CPU, 4Gb RAM, Hauppauge HVR2200 Dual Tuner, 1Tb and 500Gb WD HDDs, Windows 10 running NextPVR

lukem

#10
No worries.

This year is pretty much dedicated to Windows Media Center :)

I've released 3.0.0.29 officially.

Mozi

Quote from: Luke at IceTV on February 21, 2012, 04:05:12 PM
This year is pretty much dedicated to Windows Media Center :)

Considering that there are more than 10 months to go in this year still, that is great news  ;D Thanks, I look forward to the improvements to a great product.

tonyeliza01

I'm getting an Invalid Username/Password error from the interactive desktop client. I upgraded to 3.0.0.29 last night and this morning I'm getting an "Exception System.Net.Web Exception - The remote server returned an error: (401) Unauthorised" warning. I can log into the IceTV website with no problems. Did the upgrade stuff something up?

lukem

Hi Tony,

Could you restart the application and fill in your username/password details on first page of the application and press login again?


Eaglehawk

#14
30.0.0.30 working perfectly now.

Although the SBS TWO channel logo is missing. (ACT)

Update: But the other HTPC has the logo, but is missing all Channel 7 logos...weird...

Does anyone know what the hell is this "Television 4" channel is, and when will EPG be available for it? (If at all?)