Netgear WGT634U

Started by Mantorok, July 15, 2005, 12:59:40 PM

Previous topic - Next topic


I have noticed that there is a fully functional SSH v2 server running on the IceTV enabled NetGear router.

What are the user credentials for this?

Are they documented anywhere?


All the major components have been published either as part of the GPL release available from the IceTv GPL page or as part of the icebox project.

There are no plans to provide plaintext versions of any passwords to the public for obvious security reasons.

If you are planning on doing icebox development, I would suggest that you join the icebox-devel mailing list, hosted by the icebox project and start a conversation there.



Ok, I've had a few problems setting up my netgear still to no avail... I've spoken to the Daniels at ICE and I must thank them for their efforts so far!

Here's the story.... Um..... Three times I've locked myself out of the netgear. Twice i've sent it back to Sydney to be reflashed. Hopefully not a third time.

Here's the scenario....

I have a Wireless Access point that was originally sitting on

The third time in trying to set this up and talking with Daniel we unfortunately pointed the unit to a static IP address of and the dns/gateway settings at

We Daniel and I realised our error, we changed the IP of the access point to

When I try and access the all get is timeouts when trying to connect.

The parameters for the install are:

WEP key (128bit) enabled (hex characters only)
Pointing to the right SSID.... no problems there.

When I connect the unit to the back of my router I can see it come up on the connected ethernet devices as icebox66

But still no connection via the wireless componet.

Is there any way I can get access to my unit. Or will I have to send it back to Sydney (boo hoo....)

The next time I think i'll try the standard DHCP settings again. Does the hard-coding of the dns/gateway perm. lock me out from resetting this device?

Any help would be great!



You are probably violating a simple network topology rule and creating a routing blackhole. It sounds like you have made the same configuration error multiple times. Let's see if we can figure out where the problem is and how to get around it.

We'll need to start with a description of your existing network and how you expect to connect the Netgear to it. Please describe your existing networked equipment, how it is connected and what IP addresses and netmasks you use. Please also provide details of any network services that may be available, such as DHCP servers on access points or DNS proxies on firewalls / routers. The more information we have, the easier it is to see the whole picture.

In the case of the Netgear router, you should configure it with the least amount of information required. You should prefer DHCP over static configuration. Unless you fully understand the routing implications of a multi-homed network, I would not recommend entering any details for the static IP, default gateway or DNS servers.


Procedure for accessing a WGT634U that you think you misconfigured:
  • disconnect all cables from WGT634U, including power, network and USB
  • disconnect network cable from PC and configure network interface on PC for, netmask
  • connect power cable to WGT634U
  • wait 60 seconds
  • connect Ethernet cable between PC and WGT634U WAN port (the one next to the USB connector)
  • switch off the use of web proxies for your web browser (often called direct connection to the Internet)
  • use browser on PC to connect to
The above should work in most instances. If the above does not work, it almost certainly means that your wireless connection is working and the WGT634U is connecting to your access point. If that is the case, repeat the steps above, but ensure the access point is turned off before you start.


Hi Peter,

Thanks for the quick reply. I think personally I've made three seperate errors. The first two were definately my fault however I would have thought that the third attempt would have worked.

Here's the setup:

Wireless Access Point : Billion 7402VGP Router
PC : D-Link DWL-G122 (USB Wireless connection to my billion router)
Laptop : Work laptop connect wireless from anywhere in the house

Originally the default IP for the AP was
Netmask :

DHCP is turned on.

The only firewalls that are currently utilised are software based types ( Symantec - Internet Security 2004 ).

The subnet range is from --->

The AP is now set to ---- Both my PC and laptop connect to the access point via the SSID "WirelessNetwork". One problem that may have caused an issue was having a space in the SSID this has now been resolved. 128 bit static WEP keys are utilised to key the network (semi-secure)... Growl.... Why can't we have WPA????? Would be great to have!

So the laptop and the PC respectively are assigned and

After the first two failed attempts of me entering in 'totally' wrong addresses into the IP/DNS and gateway settings Daniel and I attempted to set it up the third time.

I disconnected everything and plugged the AP directly into the back of my PC and then plugged the netgear into the AP as well.

The netgear was assigned an ip of and the gateway/dns were pointed to

I couldn't get back in. I've tried every combination of trying to get back into the thing. Directly plugged into the AP, into the laptop, I've turned even tried turned off DHCP and assigned manual IP's to the other devices, to no avail. And to think that I'm a java programmer... Aarrrgghhh!

So when i get home tonight. I'll try the information from your second message about doing a full-reset on the netgear and see if i can get it back. If so need be I'll send it back to Sydney to get reflashed and then try the DHCP option.

Thanks for your help.



There is at least one issue I can see already, both your laptop and access point are using as their IP. That means the entire network is unstable.

Here's my recommendation for a reasonable network layout that should work rather well:

  • configure access point as netmask
  • set access point to serve DHCP in the range -
  • set laptop to use DHCP to obtain IP and network configuration
  • set desktop to use DHCP to obtain IP and network configuration
  • set WGT634U to use DHCP to obtain IP and network configuration
  • reboot access point
  • reboot laptop
  • reboot desktop
  • reboot WGT634U
  • use laptop or desktop to connect to access point and see what MAC addresses have been assigned what IP
  • if your access point supports it, configure DHCP server to always assign the same IP to a MAC address, I recommend something in the range You can do this to the WGT634U and your other devices.
Making use of DHCP is fairly important, it tends to work much better than manual configuration and the entire network ends up with consistent configuration. What's perhaps even more important, is that if you need to change things, it can be done from one place and with little scope for typos.

I still think that allowing non-DHCP configuration is more trouble than it's worth. Just about any decent access point or router out there has a DHCP server. Giving manual IP configuration access is like handing a saw over to someone sitting on a branch. You'll always find someone who will cut the wrong side.  ;)

I'm pretty confident that your configuration can be sorted out without having to send the device away.

You should ensure that your firewall is not interfering with your web browser. Software firewalls tend to be a common cause of troubles for many people. It may not be a bad idea to temporarily disable your firewall until things work.

BTW: If you think you are having trouble with this, you should see how things break when you try to get WPA working between equipment from various vendors. Trust me, you are better off with WEP for now, until WPA2 is more common.


Hi Peter,

Again thanks for the quick reply. We'll I tried the full reset and I still receive a timeout when trying to hit address.. I followed your instructions to the letter with no joy... IE basically times out.. As said, I'll send the unit back to Syndey tomorrow and will hopefully get it back before the wkend!!????

There is at least one issue I can see already, both your laptop and access point are using as their IP. That means the entire network is unstable.

Opps, that was a typo on my behalf... The current laptop IP is getting assigned a valid IP via DHCP. No conflicts are currently present on the network.

When I get the unit back, i'll carefully follow the instructions as specified and I'll set the network up now to work serve DHCP in the range -

I'll leave the static ip/dns/gateway settings alone!  :-[

Again thanks for the help!



I configured my router for a statis address mainly so I could find it on my network, as my router does not show the names of the devices connected.  It worked fine for me!



I use static addresses too.  I live in the boondocks  :) and get a fair share of power interruptions.  Because you don't know which device is going to reboot, then get on line first, fixed IPs give me the best chance, though not infallible, of everything working, (+no complaints from SWMBO) after a power bump.

Highland Valley SA (Adelaide Tx)
Beyonwiz T4 & DP-P1
oppo DV-983H, Cambridge 551R, Pioneer PDP-508XDA


I've had a toppy for over a year now and the lack of an EPG has been an ongoing source of frustration.

So last weekend I bit the bullet and took out a three month subscription to the IceTV EPG. I'm pretty happy with the way it works.

Dumping up the Guide....

I already had a USB cable in place as I'd previously used it for copying off files, so plugging in the laptop and  fetching the daily update was the easy choice. Actually doing that for the first time took longer than I expected because of the needlessly complicated instructions on the IceTV website.  Once I had the utility in place and configured it was rediculously easy to plug in the laptop once a day and do the update.

EPG Automation....

So only two days later I'm actively considering ways to automate the process. I just wanted it to work with no user intervention.

Options I considered were:
1. USB connection with an extender arrangement.
2. Connect the Toppy to the network using my Cisco NSLU2 (Slug - now overclocked and running unslung)
3. Netgear WGT634U

** I discarded option 1 mainly because my wife would have killed me if I'd added another cable to the room. The USB solution also seemed a little boring.
** I already had a SLUG onhand and I seriously considered using it. I upgraded the firmware to unslung and started playing aroung with puppy, however, the more I looked into it, the more the range of other options for this device became apparent and I started to think it would be a waste to use it on the toppy. Plus to be honest I was feeling a little lazy.
** So off to get a WGT634U.

Netgear Router....

Having read the forum I downgraded my wifi security from WPA in advance.
I downloaded the IceTV firmware, plugged in the router and using a standard cat5 cable plugged in my laptop.
No joy. I couldn't see the router admin page.
Read a little bit of the online doco and saw that I'd assumed the router would default to as all other Netgear devices do. I needed to use
Fixed that and bingo!
I flashed the firmware and it rebooted.
Tried to get back to the admin page and crap!!!! - no response.
Read a little bit of the online doco and realised I had used the wrong network port on the router. Only the port closest to the USB port was active with the new firmware.
Fixed that but still no joy.
Read a little bit more of the online doco and saw that the router was now defaulting to
Tried that and the IceGuide Page came up. So cool!

OK - After all that, configuring the router was a doddle. I guess I mucked about for 15 minutes to get it all working to my satisfaction.
Went to network settings and plugged in my SSID and WEP encryption and activated it.
Went to fetch settings and plugged in my EPG userid and password.
Did a fetch - worked fine.
Played around a bit more and updated the firmware a further two times as there were updates available.
Fetched the guide a few more times just because I could. ;)

Next Day....

Everything seems to be working fine.
As I'm typing this message everything looks sweet.
I guess it took about 45 minutes all up from unpacking the router through flashing, configuring and finally placing it in it's spot in the home theatre cabinet. I had a few minor heart palpitations after the firmware flash but really it was just me not reading all the doco.

Highly recommended.