Author Topic: [Solved (sort of)] ice EPG invalid today (it's worked up to now)  (Read 2094 times)

Offline chopper

  • Senior Member
  • ****
  • Posts: 95
    • View Profile
[Solved (sort of)] ice EPG invalid today (it's worked up to now)
« on: November 24, 2014, 07:52:12 PM »
Hello. 2 things

1. This is the new error webscheduler threw tonight.
Code: [Select]
EPG Reload/Rescan Results
==========================
About to load XMLTV Data from:
http://iceguide.icetv.com.au/cgi-bin/epg/iceguide.cgi?op=xmlguide&days=7&desc_length=0

There was an error loading the XMLTV Data!
org.xml.sax.SAXParseException; systemId: http://iceguide.icetv.com.au/iceguide/iceguide.dtd; lineNumber: 1; columnNumber: 3; The markup declarations contained or pointed to by the document type declaration must be well-formed.

I'm absolutely stuck with it like this (I cannot change the webscheduler tool). 
What changed ? (something did change, tested and got errors on 2 separate PCs using 2 different known good versions of webscheduler which have always worked up to tonight)

2. click visit forums button on https://www.icetv.com.au/cgi-bin/websupport.cgi?op=list_faq_support
gives a 404
« Last Edit: November 25, 2014, 12:44:24 PM by chopper »

Offline chopper

  • Senior Member
  • ****
  • Posts: 95
    • View Profile
Re: ice EPG invalid today (it's worked up to now)
« Reply #1 on: November 24, 2014, 08:05:33 PM »
A 3rd thing...
https://www.icetv.com.au/cgi-bin/webpage.cgi?op=show_contact
in Chrome it says
Quote
To validate this form as having live data-entry, please enter the details from the image below.
but there is no image or box or whatnot below.
ie I can't contact IceTV.

Offline chopper

  • Senior Member
  • ****
  • Posts: 95
    • View Profile
Re: ice EPG invalid today (it's worked up to now)
« Reply #2 on: November 24, 2014, 08:48:42 PM »
downloaded it manually and tried an alternate import mechanism, with this result:
Code: [Select]
Loading XMLTV data from data\xmltv\2014.11.25.xml
There was an error loading the XMLTV Data!
org.xml.sax.SAXParseException; lineNumber: 275; columnNumber: 31; The entity name must immediately follow the '&' in the entity reference.
at com.sun.org.apache.xerces.internal.parsers.DOMParser.parse(Unknown Source)
at com.sun.org.apache.xerces.internal.jaxp.DocumentBuilderImpl.parse(Unknown Source)
at javax.xml.parsers.DocumentBuilder.parse(Unknown Source)
at GuideStore.loadXMLdata(GuideStore.java:650)
at GuideStore.loadXMLTV(GuideStore.java:343)
at EpgDataRes.reloadXMLTVdata(EpgDataRes.java:1773)
at EpgDataRes.getResponse(EpgDataRes.java:49)
at HTTPRequest.sendResponseData(HTTPRequest.java:124)
at RequestObject.run(RequestObject.java:144)
at java.lang.Thread.run(Unknown Source)
EPG Data Load Failed!
Line 275 is
Quote
<category lang="en">Business & Finance</category>
Looks like a bare "&" is an invalid character.
Please fix.

Offline freewuns

  • Junior Member
  • **
  • Posts: 10
    • View Profile
Re: ice EPG invalid today (it's worked up to now)
« Reply #3 on: November 25, 2014, 08:40:47 AM »
I had same problem and only started last night. All was OK Sunday night! I also posted here....

http://forum.icetv.com.au/iceforum/index.php/topic,4403.0.html

The body of the error is the same but the first line is different to yours....

There was an error loading the XMLTV Data!

org.xml.sax.SAXParseException; systemId: http://iceguide.icetv.com.au/iceguide/iceguide.dtd; lineNumber: 1; columnNumber: 3; The markup declarations contained or pointed to by the document type declaration must be well-formed.
   at com.sun.org.apache.xerces.internal.parsers.DOMParser.parse(Unknown Source)
   at com.sun.org.apache.xerces.internal.jaxp.DocumentBuilderImpl.parse(Unknown Source)
   at javax.xml.parsers.DocumentBuilder.parse(Unknown Source)
   at GuideStore.loadXMLdata(GuideStore.java:617)
   at GuideStore.loadXMLTV(GuideStore.java:337)
   at EpgDataRes.reloadXMLTVdata(EpgDataRes.java:1835)
   at EpgDataRes.getResponse(EpgDataRes.java:49)
   at HTTPRequest.sendResponseData(HTTPRequest.java:94)
   at RequestObject.run(RequestObject.java:145)
   at java.lang.Thread.run(Unknown Source)

« Last Edit: November 25, 2014, 08:42:36 AM by freewuns »

Offline Daniel Hall at IceTV

  • Administrator
  • Guru
  • *****
  • Posts: 1225
    • View Profile
    • IceTV
Re: ice EPG invalid today (it's worked up to now)
« Reply #4 on: November 25, 2014, 08:46:34 AM »
Hi Chopper,

Please try reloading the data in TV Scheduler Pro, you may however need to restart the computer to ensure a redirection is not being cached.

In terms of escaping characters, this has not changed so the second error would have more to do with how the file was manually downloaded. More than likely the manual method processed and removed the escape characters.
Regards,

Daniel.
CTO.

Offline chopper

  • Senior Member
  • ****
  • Posts: 95
    • View Profile
Re: ice EPG invalid today (it's worked up to now)
« Reply #5 on: November 25, 2014, 12:44:01 PM »
OK, thanks Daniel.

Re-tried the automated reload function which had failed on multiple PCs last night, and now it works ... with no changes made at my end ... :)

Yes, quite right, I double checked and the manual download process used to test it did not reflect the actual source.

How strange.

Cheers
« Last Edit: November 25, 2014, 12:46:31 PM by chopper »


Share via facebook Share via twitter

clip
[SOLVED] "Channel could not be opened." error when setting up

Started by DaveQB on MythTV

1 Replies
2522 Views
Last post March 21, 2018, 03:05:00 PM
by DaveQB
xx
[Solved] Search may have an issue...

Started by bodogbodog on Windows Vista Media Center

3 Replies
1787 Views
Last post November 23, 2009, 08:31:56 PM
by bodogbodog