Author Topic: I am confused!  (Read 2550 times)

Offline csutak40

  • Guru
  • *****
  • Posts: 1147
    • View Profile
I am confused!
« on: August 06, 2009, 08:00:20 PM »
I mainly use Toppy, but also use Media Center as a backup.  There are a few things I always record through it, mostly shows that I plan to burn.  I was looking forward (not >:() to remapping it once again, because of GO!.  I was going to do that on the weekend or whenever I got around to it - no hurry. 

I noticed in the last few days that a program hasn't recorded.  I had a look and it turned out all my scheduled recordings had a yellow exclamation mark next to them.  I clicked on "reschedule recording", which has worked for me before.  I reset everything, but MC still had no recording set.  As one of them is Law & Order tonight, I thought I will have to remap it earlier than I planned, but in the meantime I was just going to manually record L&O.  I discovered I had no Channel 10!  Seems (didn't think of it before)  all my scheduled recordings are on 10!  So, on further investigation, I discovered that 9 GO! has appeared all by itself, but 10 somehow hot dropped.  How is that possible?
Cheers,
Judy
Windows 7 Media Center; Last Update Feb 20 2006; Beyonwiz T4, T2

Offline Mark

  • Junior Member
  • **
  • Posts: 27
    • View Profile
Re: I am confused!
« Reply #1 on: August 07, 2009, 08:55:49 AM »
I have the same issue, and missed The Simpsons on Wednesday because of it.  I have posted in the forum for Vista Media Center, but it seems that nobody else cares  :)

The issue seems to arise because of the way that Microsoft has implemented guide listings in MCE.  There is nothing Ice can do about this, but given that it is predictable and unavoidable a bit of advance warning would be nice (is anyone at Ice listening?!)

In addition to channel numbers and names, MCE maintains an internal "ServiceID" number.  This is just an index number for each listing in the guide, as far as I can tell.  This index number seems to be used as the "key" for scheduled recordings.  So if somebody inserts a new channel listing into the guide, the index numbers of all listings after the insertion increase by one.  For all existing scheduled recordings affected by this change, the index numbers will no longer match the other information (eg the channel name/number), and this causes MCE not to schedule the recordings at all.  However, if you look at your scheduled series recordings, everything appears OK and there is no obvious reason why the recordings are not happening.

In this case, ABC1/2, Seven and Nine all precede the new GO data in the guide, so scheduled recordings for these channels are OK.  But Ten and SBS ONE/TWO (at least) are "above" the inserted channel, and thus all scheduled recordings on these channels fail.  You can see all this stuff in the Recordings.xml file (in my case, for example, Ten went from ServiceID=13 to ServiceID=14).

The only sure-fire fix is to go back and set up your guide listings from scratch again.  Once you have done this, all your series recordings will still be there, but the "corrupted" ones will now be set to record on the wrong channels.  You need to cancel and reschedule each one of these to reassociate them with the correct channel.

I am not sure if it is possible, but if new channel listings could be added to the end of the guide, rather than in the middle, then the transition would probably be a lot less disruptive for us poor MCE users...
« Last Edit: August 07, 2009, 08:58:27 AM by Mark »

Offline Russell at IceTV

  • Guru
  • *****
  • Posts: 444
    • View Profile
Re: I am confused!
« Reply #2 on: August 07, 2009, 09:02:19 AM »
Hi guys,

Sorry about this problem.  We'll look into it and see if we can find a solution to keep MCE from moving the channels around.

Russell


Share via facebook Share via twitter

xx
Search Options

Started by raymondjpg on General Discussions

4 Replies
42 Views
Last post August 07, 2020, 07:14:34 PM
by raymondjpg
xx
V8 Supercars Darwin event originally scheduled for this weekend - now postponed

Started by grumpy_geoff on IceTV EPG Content

0 Replies
32 Views
Last post August 06, 2020, 10:35:14 PM
by grumpy_geoff
xx
epg content missing for Adelaide SBS VICELAND HD

Started by chopper on IceTV EPG Content

3 Replies
65 Views
Last post August 04, 2020, 04:54:56 PM
by chopper
xx
The Bletchley Circle...

Started by Garyvx on IceTV EPG Content

1 Replies
71 Views
Last post August 02, 2020, 09:55:02 AM
by GaiO IceTV