Author Topic: T4 missing Ten HD guide info 5pm to midnight.  (Read 162 times)

Offline Pauloz53

  • Junior Member
  • **
  • Posts: 18
    • View Profile
T4 missing Ten HD guide info 5pm to midnight.
« on: October 15, 2017, 03:44:14 PM »
My T3 and P2 are normal as is the web app but the T4 is missing the guide info for only Ten HD tonight.

Tried resending all timers but no change. Log simply says epg update ok. Rebooted the T4 but no change. Guide is empty 5 to12pm. Timer for Bull is present though so only the guide is missing.

Switching to FTA the problem is not present but reappears when I switch back to IceTV.

Any clue how to fix this problem?

Offline grumpy_geoff

  • Full Member
  • ***
  • Posts: 31
    • View Profile

Offline MD

  • Senior Member
  • ****
  • Posts: 104
  • TV TV Australia MD
    • View Profile
Re: T4 missing Ten HD guide info 5pm to midnight.
« Reply #2 on: October 15, 2017, 05:11:40 PM »
We have a blank guide problem unique to 16 bit T4s. Weíve submitted a fix to prl who is writing a plug in update. So if itís just a guide section thatís gone awry bear with us and it should be fixed shortly. Iím not sure but i think if the guide still has blank time sectors for Ch10 it should record from our app or website.

Offline MD

  • Senior Member
  • ****
  • Posts: 104
  • TV TV Australia MD
    • View Profile
Re: T4 missing Ten HD guide info 5pm to midnight.
« Reply #3 on: October 15, 2017, 05:14:17 PM »
Typo - T series

Offline grampus

  • IceTV Beta
  • Guru
  • *
  • Posts: 327
    • View Profile
BeyonWiz, T3

Offline Pauloz53

  • Junior Member
  • **
  • Posts: 18
    • View Profile
Re: T4 missing Ten HD guide info 5pm to midnight.
« Reply #5 on: October 15, 2017, 06:40:45 PM »
Just been in an exchange with PRL on the wiz forum. He agrees that it's likely to be that bug.

Yes, the timer is still present so hopefully it will be resolved by a plug-in update.

Thanks, Paul

Offline prl

  • Guru
  • *****
  • Posts: 2898
    • View Profile
Re: T4 missing Ten HD guide info 5pm to midnight.
« Reply #6 on: October 15, 2017, 06:47:08 PM »
I've just got back from an Internet-free week on Norfolk Island to see an email from Daniel Hall at IceTV saying that he's implemented the IceTV-side changes needed to fix the problem.

Corresponding changes need to be made on the Beyonwiz side, and I'll do that ASAP. When I'm satisfied with my own testing, I'll make patches available to IceTV and on the Beyonwiz forum to allow anyone else who wants to be on the bleeding edge to give it a go. I'll endeavour to make the patches compatible with both the latest official version and with the latest beta.

Like grumpy_geoff, I'm puzzled why Pauloz53 is seeing the problem on his T3, but not on his T4, since the issue that I think is the cause is common to all Beyonwiz T series models.

The "16 bit" reference that Colin (MD) made is to the fact that IceTV event ids are 47 bits, or more accurately, 13 decimal digits (IIRC), but the Beyonwiz T series can only store 16-bit event ids. That can cause two (or more, but that's fairly unlikely) distinct IceTV event ids to be mapped to the same Beyonwiz internal event id. Because of the way that the IceTV event ids are allocated, if collisions happen, they're likely to happen in runs, and so the missing parts of the EPG tend to be a run of several programs. For more information than you really wanted to know about the problem, see the Beyonwiz issue tracker item Bug #603: Gaps in IceTV EPG. For even more excruciating detail, see Gaps in IceTV EPG on the Beyonwiz forum.
Peter
Beyonwiz T4 in-use
Beyonwiz T2, T3 & T4 for testing

Offline prl

  • Guru
  • *****
  • Posts: 2898
    • View Profile
Re: T4 missing Ten HD guide info 5pm to midnight.
« Reply #7 on: October 16, 2017, 10:35:11 AM »
Possibly 'EIT event id collision' -
http://forum.icetv.com.au/iceforum/icetv-epg-content/5/epg-blanks-sbs-1/5744/
http://forum.icetv.com.au/iceforum/icetv-epg-content/5/7flix-epg-blank-saturday-16th/5750/

Puzzling why your T34 is immune though?

One possibility was that the setting of MENU>Setup>TV>EPG settings>Keep old EPG for minutes was the cause of the difference, but Paul has since posted on the Beyonwiz forum that both machines have the same setting for Keep old EPG, so that's ruled out as a cause.

The reason why it can make a difference to the bug is that if more of the old EPG is retained, there are more EPG entries that might collide.

Offline prl

  • Guru
  • *****
  • Posts: 2898
    • View Profile
Re: T4 missing Ten HD guide info 5pm to midnight.
« Reply #8 on: October 19, 2017, 11:12:06 AM »
The fix for this problem has been implemented on the IceTV side. I've written and started testing the fix for the Beyonwiz side, and given a copy of the fix to Daniel Hall for testing by IceTV.

If that goes well, I'll make an alpha patch available on the Beyonwiz forum for those willing to try it out. A proper public beta or official version probably won't be available until the new U4 model's initial firmware has been finalised (but that decision isn't up to me).


Share via facebook Share via twitter

xx
Two T4's ...

Started by xanthi on Beyonwiz

1 Replies
263 Views
Last post May 19, 2017, 10:28:52 AM
by prl
xx
Dr Who record request not sent through to T4 unit

Started by Andrew Smith on IceTV EPG Content

1 Replies
152 Views
Last post April 30, 2017, 09:29:59 PM
by Andrew Smith
xx
Can't login to IceTV - new T4

Started by Pauloz53 on Beyonwiz

2 Replies
515 Views
Last post November 16, 2016, 05:08:00 PM
by Dave at IceTV
clip
Naming on T4

Started by csutak40 on Beyonwiz

8 Replies
1322 Views
Last post September 17, 2016, 11:07:34 AM
by vader1111